[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#622649: linux-image-2.6.38-2-amd64: unable to enumerate USB device on port 6



Am Freitag, 15. April 2011 schrieb Hans-J. Ullrich:
> > I'll handle this, Alan.
> > 
> > Ben.
> 
> Thank you very much, Ben!
> 
> Hans
Hi Ben, Alan and Jonathan,

I was not lazy and again tried to rebuild the module(s) with the patched 
source-code, but did not succeed. I downloaded the kernel-sources, unpacked 
them to /usr/src and then linked the sources to /usr/src/linux.

Copying /boot/config-2.6.38-2-amd64 to /usr/src/inux/.config.
Then started make menuconfig and added in version option "-2-amd64", to make 
sure I have the same version than the running kernel.

After this I started "make modules" below /usr/src/linux, to build just the 
modules. After building them, I copied "ohci-hcd.ko" and "ehci-hcd.ko" to 
/lib/modules/2.6.38-2-amd64/drivers/usb/host and overwrote the existing *-
hcd.ko modules.

With "depmod -a" I finished.

But I can still not load those kernel modules. I also remarked, the new ones 
are much bigger (old ones are about 60kB, the new ones about 700kB).

I also tried "make-kpkg --append-to-version=-2-amd64 modules_image" but the 
process stops at the point, where it wants to clean up ( /usr/bin/make clean 
is the last line I see).

What did I do wrong? In the past, I already build some kernels, but the last 
one was a long time ago (I think, it was 2.6.20 something) and did it by using 
make-kpkg.

However, when the patched kernel-package is uploaded, Or if you will send me a 
download-link to a package, I will be very pleased to test it!

Thank you very much for your help.

Cheers


Hans 



Reply to: