[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#606889: linux-2.6: Failed to load ngene (v4l driver) with error -5



Hi,

when i use the same driver within a lenny domU the driver is loading without any problems. It seams to be a problem under squeeze when ngene tries to register the new adapter for the card.

Here is the dmesg output of the lenny domU.
[    4.735990] nGene PCIE bridge driver, Copyright (C) 2005-2007 Micronas
[    4.736254] ngene 0000:00:01.0: enabling device (0000 -> 0002)
[    4.736408] ngene: Found Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
[    4.738269] PCI: Setting latency timer of device 0000:00:01.0 to 64
[    4.738372] ngene: Device version 1
[    4.738399] firmware: requesting ngene_15.fw
[    4.781654] ngene: Loading firmware file ngene_15.fw.
[    4.795122] DVB: registering new adapter (nGene)
[    5.001116] LNBx2x attached on addr=a
[    5.001133] DVB: registering adapter 1 frontend 0 (STV090x Multistandard)...
[    5.022238] stv6110x_attach: Attaching STV6110x
[    5.022253] DVB: registering new adapter (nGene)
[    5.174364] LNBx2x attached on addr=8
[    5.174380] DVB: registering adapter 2 frontend 0 (STV090x Multistandard)...
[    5.174470] stv6110x_attach: Attaching STV6110x

regards
Herbert

-----Ursprüngliche Nachricht-----
Von: kloana <kloana@web.de>
Gesendet: 12.12.2010 19:20:09
An: "Debian Bug Tracking System" <submit@bugs.debian.org>
Betreff: Bug#606889: linux-2.6: Failed to load ngene (v4l driver) with error -5

Package: linux-2.6
Version: linux-image-2.6.32-5-xen-amd64
Severity: normal

The compiling of the v4l ngene driver is working without any problems, but loading the new module won't work. In dmesg i get the error -5.
[   22.641167] nGene PCIE bridge driver, Copyright (C) 2005-2007 Micronas
[   22.641336] ngene 0000:00:01.0: enabling device (0000 -> 0002)
[   22.641450] ngene 0000:00:01.0: Xen PCI enabling IRQ: 16
[   22.641462]   alloc irq_desc for 16 on node 0
[   22.641467]   alloc kstat_irqs on node 0
[   22.641492] ngene: Found Linux4Media cineS2 DVB-S2 Twin Tuner (v5)
[   22.642176] ngene 0000:00:01.0: setting latency timer to 64
[   22.642276] ngene: Device version 1
[   22.642333] ngene 0000:00:01.0: firmware: requesting ngene_15.fw
[   22.682246] ngene: Loading firmware file ngene_15.fw.
[   24.692038] ngene: Command timeout cmd=11 prev=02
[   24.692055] host_to_ngene (c000): 01 f8 0e 00 00 00 00 00
[   24.692067] ngene_to_host (c100): 00 00 00 00 00 00 00 00
[   24.692078] dev->hosttongene (ffff88003e88d000): 11 01 00 d0 00 04 00 00
[   24.692088] dev->ngenetohost (ffff88003e88d100): 00 00 00 00 00 00 00 00
[   24.692249] ngene: probe of 0000:00:01.0 failed with error -5


-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-xen-amd64 (SMP w/1 CPU core)
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)
Shell: /bin/sh linked to /bin/dash



-- 
To UNSUBSCRIBE, email to debian-kernel-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Archive: 20101212182009.667.43168.reportbug@mythtvbackendtesting.lueger.or.at">http://lists.debian.org/20101212182009.667.43168.reportbug@mythtvbackendtesting.lueger.or.at
___________________________________________________________
GRATIS! Movie-FLAT mit über 300 Videos. 
Jetzt freischalten unter http://movieflat.web.de



Reply to: