[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#602642: nfs-kernel-server: Crossmnt stopped working after upgrade from Lenny to Squeeze

Package: nfs-kernel-server
Version: 1:1.1.2-6lenny2
Severity: important

Upgraded file server from Lenny to Squeeze. After upgrade NFS clients failed to
access bind mounted subdirectories on NFS server, error message about stale NFS

Basic setup on "fileserver":

/dev/md0 is mounted at /mnt/md0 in fstab
/mnt/md0/raid is bind mounted at /data/raid in fstab

/etc/exports looks like this:
/data     ,no_subtree_check,crossmnt)

NFS clients mount fileserver:/data.

This setup has been used for about a year. After "fileserver" was upgraded to
Squeeze the clients could mount fileserver:/data but not access the raid
subfolder, got an error message about stale NFS handle.

Downgrading nfs-kernel-server and nfs-common to Lenny versions
(1:1.1.2-6lenny2) restored functionality.

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.32-5-amd64 (SMP w/1 CPU core)
Locale: LANG=sv_SE.UTF-8, LC_CTYPE=sv_SE.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages nfs-kernel-server depends on:
ii  libblkid1                2.17.2-3.3      block device id library
ii  libc6                    2.11.2-7        Embedded GNU C Library: Shared lib
ii  libcomerr2               1.41.12-2       common error description library
ii  libgssglue1              0.1-4           mechanism-switch gssapi library
ii  libkrb53                 1.8.3+dfsg-2    transitional package for MIT Kerbe
ii  libnfsidmap2             0.23-2          An nfs idmapping library
ii  librpcsecgss3            0.19-2          allows secure rpc communication us
ii  libwrap0                 7.6.q-19        Wietse Venema's TCP wrappers libra
ii  lsb-base                 3.2-23.1        Linux Standard Base 3.2 init scrip
ii  nfs-common               1:1.1.2-6lenny2 NFS support files common to client
ii  ucf                      3.0025+nmu1     Update Configuration File: preserv

nfs-kernel-server recommends no packages.

nfs-kernel-server suggests no packages.

-- no debconf information

Reply to: