[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#599927: marked as done (Kernel crashes when I start X on my Dell Latitude D505)

Your message dated Wed, 13 Oct 2010 14:48:32 +0200
with message-id <20101013124832.GY2854@radis.liafa.jussieu.fr>
and subject line Re: Bug#599927: Kernel crashes when I start X on my Dell Latitude D505
has caused the Debian Bug report #599927,
regarding Kernel crashes when I start X on my Dell Latitude D505
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

599927: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599927
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: linux-image-2.6.32-5-686
Version: 2.6.32-23
Severity: important

The X server involved is as far as I know xserver-xorg-video-intel
version 2:2.9.1-4.

When I install the current Squeeze on my test laptop, a Dell Latitude
D505, starting kdm kill the machine.

This is what happen when I start X manually when logged in via ssh:

  root@pxe-test0-pre:~# X

  X.Org X Server 1.7.7
  Release Date: 2010-05-04
  X Protocol Version 11, Revision 0
  Build Operating System: Linux 2.6.32-5-686 i686 Debian
  Current Operating System: Linux pxe-test0-pre.uio.no 2.6.32-5-686 #1 SMP Sat Sep 18 02:14:45 UTC 2010 i686
  Kernel command line: BOOT_IMAGE=/vmlinuz-2.6.32-5-686 root=/dev/mapper/vg_system-root ro quiet
  Build Date: 20 September 2010  03:40:46PM
  xorg-server 2:1.7.7-7 (Julien Cristau <jcristau@debian.org>)
  Current version of pixman: 0.16.4
          Before reporting problems, check http://wiki.x.org
          to make sure that you have the latest version.
  Markers: (--) probed, (**) from config file, (==) default setting,
          (++) from command line, (!!) notice, (II) informational,
          (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
  (==) Log file: "/var/log/Xorg.0.log", Time: Tue Oct 12 15:26:01 2010
  (==) Using system config directory "/usr/share/X11/xorg.conf.d"
  (EE) open /dev/fb0: No such file or directory

After this, the network connection is dead and the screen and keyboard
on the laptop is black and dead.

I was a similar problem with Ubuntu earlier, reported at
<URL: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/592682 >.

As the workaround for Ubuntu mentioned the file
/etc/modprobe.d/i915-kms.conf and changing modeset there, I tried to
change the current 'modeset=1' to 'modeset=0' and ran
'update-initramfs -u' before testing a reboot, but the problem was
still there.

Not quite sure what more to test.  Any suggestions?  I'm unable to get
any kernel messages from the crash.  Tried tailing /var/log/syslog
over ssh, but no messages showed up.

Happy hacking,
Petter Reinholdtsen

--- End Message ---
--- Begin Message ---
Version: 2.6.32-24

On Wed, Oct 13, 2010 at 14:42:59 +0200, Petter Reinholdtsen wrote:

> When I now start kdm, the login screen show up as it should.  I guess
> the default X screen was just black, and starting kdm changed the
> colors to something more interesting. :)
Yes, X comes up with a black screen and no cursor by default (not very
helpful for debugging, but oh well).  X -retro brings back the old
stipple and cross-shaped cursor.

> I guess the conclusion is that the kernel and intel Xorg driver in Sid
> work just fine.  I hope the new packages make it into Squeeze.
They will.  Thanks for testing.


Attachment: signature.asc
Description: Digital signature

--- End Message ---

Reply to: