[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#598803: xserver-xorg-video-intel: X crashes / hung gpu, now and then

CCing the kernel team for letting them know.

On 10/02/2010 01:45 PM, Steinar H. Gunderson wrote:
I'm seeing the issue of hung GPU, after which a lot of applications (in
particular urxvt) become very messed up. Restarting X does not help for me.

   [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
   [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting
   3894 at 3893)
   [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung

Hello Steinar, can you tell us what's your chipset?

I ask you because, reading from debian-x ml seems that people with chipset like i830, i845 keep on seeing this kind of problem.

I have an i855 and i'm here to say to the Debian X strike force and to the debian kernel team that the combination of 2.6.32-24 (and above) and 2.12.0+shadow-2 is a great improvement for me: after about a week of hour and hour of work with this x driver and 2.6.35-rc6 i haven't seen an hang or a video problem (i scaramantically touch iron saying this). I've also noted on debian-x that complains about i855 seems to have fallen down and many bugs were closed, isn't it?

I can reproduce it 100% reliably by trying to play
http://www.youtube.com/watch?v=IrwjatDnLKY in Google Chrome with HTML5

I can reproduce this video without problem, also going fullscreen (in the past week this operation caused me freeze or X restarting itself).

It'd be nice to know how it goes with 2.13.0-1 (just uploaded to
experimental, so available in a few hours).

I'm waiting to try. It's not on my mirror yet.



Reply to: