[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#593683: linux-2.6 - images does not conflict with pre-policy versions of bootloaders



On Sun, Sep 19, 2010 at 08:53:07PM +0100, Ben Hutchings wrote:
> > grub uses a public interface. There is no need for depends in this case.
> > However if the public interface is changed, it needs to be handled
> > accordingly.

> And the public interface hasn't changed.

In my testing, I can confirm that installing a squeeze kernel package on a
system with lenny grub succeeds in updating /boot/grub/menu.lst without
incident.  So you may be right that this is a non-issue.  I'm asking the
folks who commented on the mailing list for logs, to help pinpoint if
there's something here that we've overlooked; but we shouldn't hold up our
call for upgrade testing waiting for such logs to appear, in the absence of
some other evidence of a problem when using grub.

Thanks,
-- 
Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
Ubuntu Developer                                    http://www.debian.org/
slangasek@ubuntu.com                                     vorlon@debian.org

Attachment: signature.asc
Description: Digital signature


Reply to: