[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#596390: Log messages from 2.6.30 and 2.6.32

On Sat, 2010-09-11 at 16:02 -0600, Shawn Heisey wrote:
> On 9/11/2010 10:46 AM, Ben Hutchings wrote:
> > On Sat, 2010-09-11 at 01:03 -0600, Shawn Heisey wrote:
> >> On 9/10/2010 4:57 PM, Ben Hutchings wrote:
> >>   >  Please test a newer version.  There was a bug fix to r8169 in version
> >>   >  2.6.32-16 which might address this.
> >>
> >> I've already got 2.6.32-20, significantly newer than the -16 you're
> >> mentioning.
> > [...]
> >
> > But the log you sent is from 2.6.32-15.  Please send a log from the
> > newer version.
> >
> I guess I grabbed the wrong part of the kern.log file.  Apologies.  I'm 
> including the one with -20 that didn't work several days ago, and then 
> the one from -21 last night.  On the -21 log, the result was the same at 
> first, then I got logged into the console and you'll see the link go up 
> and down multiple times from the troubleshooting that eventually led to 
> hard-setting both sides to 100/Full.
> The reason there are two lines of "link down" in the -15 and the -20 
> logfile is because at the time, I had put a pre-up command in 
> /etc/network/interfaces that turned autoneg off and then back on.  One 
> of the many messages I read while researching this problem said that 
> this worked for them.  It wasn't helping, so I removed it.
> I have tried multiple cables and multiple ports on the switch.  
> Everything works with 2.6.30, but not 2.6.32.

Please try this while running kernel version 2.6.32:
1. Enable additional error logging by running: ethtool -s eth0 msglvl 0x3f
2. Enable autoneg again
3. Disconnect and reconnect the cable
4. Check for any new error messages in the kernel log

Also send the output of each of these commands when autoneg is enabled
and the cable connected, under 2.6.30 and under 2.6.32:
1. ethtool eth0
2. ethtool -d eth0
3. mii-tool eth0


Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: