[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#595103: xwindows gone starting at 2.6.32-21

>>>>> "BH" == Ben Hutchings <ben@decadent.org.uk> writes:

BH> On Wed, 2010-09-01 at 11:38 +0800, jidanni@jidanni.org wrote:
>> Package: linux-2.6
>> Version: 2.6.32-21
>> Severity: important
>> Upon upgrading to -21 xdm nor nodm will not start.
>> -20 worked fine.
>> /var/log/Xorg.0.log says
>> (EE) open /dev/fb0: No such file or directory
>> (EE) intel(0): No kernel modesetting driver detected.
>> (II) UnloadModule: "intel"
>> (EE) Screen(s) found, but none have a usable configuration.
>> Fatal server error:
>> no screens found
BH> [...]

BH> Which version of xserver-xorg-video-intel are you using?
Indeed, that combined with _your bad kernel_ caused me several times to
have to hit the power button, as ALT+CTRL+F1, SysRq... all didn't work.
My disks had to be fscked all over again and fsck even exited with value
1 etc. misery.
Only after downgrading xserver-xorg-video-intel from 2:2.12.0+legacy1-1 to 2:2.11.0-1.
was I able to even get the above error messages, else nothing was even
written to disk.
Then I tried downgrading the kernel. That fixed it. So I now upgraded
xserver-xorg-video-intel back.

So now I can use what I get with a aptitude full-upgrade here on sid, with only forbidding
your bad kernel.

Reply to: