[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#594554: linux-image-2.6.35-trunk-amd64: pl2303 module needs to be first unloaded to make my GPS data logger work



On Fri, 2010-08-27 at 08:59 +0200, Julien Valroff wrote:
> Package: linux-2.6
> Version: 2.6.35-1~experimental.2
> Severity: normal
> 
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Hi,
> 
> I have recently acquired a GlobalSat DG-100 Data Logger, reported to work perfectly with the pl2303 module.
> 
> when I plug this GPS into the usb port, the module is loaded automatically, but utility software
> such as gpsbabel and josm (just examples) cannot communicate with the device.
> 
> I first need to unloaded the pl2303 module by hand, switch off the GPS, and switch it on again. The module is
> ten automatically loaded again and everything works as expected.
> 
> I have tried loading the pl2303 by hand before plugging the device or loading it via /etc/modules at boot, with no
> success in both cases.
> 
> I attach the kernel log for the whole sequence (plugging the device, unloading the module, switching off & on the device).
[...]

This doesn't show any problems.  It appears to me that you have
installed some program that automatically opens the device when you
first plug it in (this happened about 0.028 seconds later), and that
this prevents it from being used by other programs.

Ben.

-- 
Ben Hutchings
Once a job is fouled up, anything done to improve it makes it worse.

Attachment: signature.asc
Description: Digital signature


Reply to: