[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#582858: initramfs-tools: MODULES=dep fails when / is ubifs

On 06/08/2010 03:31 PM, Martin Michlmayr wrote:
> * Daniel Kahn Gillmor <dkg@fifthhorseman.net> [2010-06-08 15:22]:
>>>> rootfs on / type rootfs (rw)
>>>> ubi0:root on / type ubifs (rw,relatime)
>      ^^^^^^^^^
> This is the output from 'mount', and here's what i-t does:
>     eval "$(mount | awk '/\/dev\// {if ($3 == "/") {print "root=" $1 "\nFSTYPE=" $5; exit}}')"
> it looks for something with /dev/ in it.  In your case, this does't
> match so root= and FSTYPE= are empty.  I think we should simply add a
> check to i-t at this point to produce an error when $root is empty.
> Daniel, do you know if ubi0:root in /etc/fstab is valid?  Is that what
> the ubi people recommend to use?  Shouldn't this be a device like
> /dev/ubiX_Y?  (This would make i-t happy)

according to:


the /dev/ubiX_Y method is the recommended method for newer kernels.

however, i was unable to get that to work when i tried with
2.6.32-5-kirkwood (unfortunately, i don't have a log of that interaction
-- would one be useful?).

The old-style "device-less" method worked for me, though (and appears to
be reflected in /proc/mounts).


Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: