[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#580925: closed by maximilian attems <max@stro.at> (Re: Bug#580925: This error is presenting while installing linux-image-2.6.32-5-686:)

Op (10/05/10 22:27), yanu schreef:
> > On Sun, May 09, 2010 at 11:19:29PM +0200, yanu wrote:
> > > Running update-grub.
> > > Generating grub.cfg ...
> > > /usr/sbin/grub-probe: error: no mapping exists for `md5'.
> > 
> > fix your grub.cfg, if you don't know how to do this ask on
> > a debian userlist, not a linux-2.6 bug thus closing.
> Ok, thx, i solved it myself.
> I thought the 'md5'-part had something to do with enscryption ... but i was wrong.
> /dev/md5 is my root-device.
> So the problem was solved when i renamed the devices in /etc/fstab with the UUID's, as the installationproces of the kernel mentioned.
> After a reboot and an "apt-get install --reinstall linux-image-2.6.32-5-686" solved that one.

Just for others that have the same problem:

This problem appeared again when installing a new kernel.

After some searching, i found it was /boot/grub/device.map that was causing this trouble.
I renamed (then removed) that file and reinstalled the kernel.
Now everything is fine.

/boot/grub/device.map was made in the time grub couldn't boot a md-partition ... a long time ago ;)

Groeten Lieven Baes aka yanu

Reply to: