[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#573007: NIC r8169 doesn t start at restart on kernel linux-image-2.6.32-trunk-686

On Wed, 2010-03-24 at 08:21 +0100, spitzauer_77@gmx.de wrote:
> Hi,
> yesterday i mad an "aptitude full-upgrade" because i saw the new
> kernel image 2.6.32-3-686, which may correct my problem.
> But now i have really serious problem. The Ethernet is still not
> working with this kernel and Knoppix too!!! So my rtl8169 is broken
> and i cannot make that workaround with Knoppix. I had no time to
> investigate this more.
> But maybe it's a firmware problem, because if i made "aptitude
> full-upgrade" i saw this:
> update-initramfs: Generating /boot/initrd.img-2.6.32-3-686
> W: Possible missing firmware /lib/firmware/rtl8168d-2.fw for module r8169
> W: Possible missing firmware /lib/firmware/rtl8168d-1.fw for module r8169
> Running update-grub.

Only the RTL8168D chips want this firmware, and they appear to mostly
work without it.

> I tried also Adrien Clerc tip, without success.
> Hopefully my onboard network cards have no hardware damage.
> Any Suggestion? Thanks!

I don't think I saw your original bug report, but the problem seems to
be that the hardware is failing to read all of the MAC address out of

[    4.867561] eth0: RTL8169sc/8110sc at 0xf7c94000, 00:00:00:00:c0:e7, XID 18000000 IRQ 18
[    4.875112] eth1: RTL8169sc/8110sc at 0xf7cf0000, 00:00:00:00:c0:e8, XID 18000000 IRQ 19

[    4.868080] eth0: RTL8169sc/8110sc at 0xf7ce2000, 00:30:18:b0:c0:e7, XID 18000000 IRQ 18
[    4.937598] eth1: RTL8169sc/8110sc at 0xf7d2e000, 00:30:18:b0:c0:e8, XID 18000000 IRQ 19

I don't see any changes to r8169 between kernel versions 2.6.26 and
2.6.32 that might explain this, but it could be dependent on timing.

You may be able to work around this for now:
1. In /etc/udev/rules.d/70-persistent-net.rules, map the broken MAC
addresses to eth0 and eth1.
2. In /etc/network/interfaces, use the hwaddress setting to fix the MAC


Ben Hutchings
I haven't lost my mind; it's backed up on tape somewhere.

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: