[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: adding pre-juju firewire modules back into lenny

hello john,

please be so polite to ask the mailinglist.
it is not like i'd did such a decision on my own.
so if you respond to this keep it on cc, thanks.

On Thu, Mar 04, 2010 at 11:48:22AM -0800, john boyd wrote:
> Hi,
> I'm going to be nice and politely ask you to point me to links that shows me
> the steps to adding back in the previous firewire stack.  It appears that I
> am having similar problems like others.  I'm not finding much more than
> these cursory details in resolving the issue:
> http://www.mail-archive.com/debian-kernel@lists.debian.org/msg34998.html

the decision didn't go through for lenny as userspace libraries
didn't catch up quickly enough. so your trouble is quite a different

> I don't give a fig about security for this box, I just want to be able to
> mount my new sata based terrabyte drive (that is in a firewire enclosure).
> The machine is a PowerMac G4 Titanium running Debian ppc Lenny.  My old
> smaller external firewire ide based drives mount fine, but my new external
> fw enclosure with a SATA based drive on the inside fails and I only get this
> in the logs with no mount or output from "fdisk -l":
> [12718.287534] ieee1394: Node added: ID:BUS[0-00:1023]
> GUID[001b8cc732535841]
> [12718.287692] ieee1394: Host added: ID:BUS[0-01:1023]
> GUID[000393fffedb2a5e]

this shows clearly old firewire stack.
> I've tried several of the modprobe parameters with no luck.  I also tried 2
> different pcmcia firewire cards (1 was a Lacie pccard that worked in OSX)
> but I didn't see anything in the logs that even saw the cards.
> It's been many many years since I've built my own kernel/modules and that
> was on another version of Linux altogether.    Any links that help clarify
> this particular process would be appreciated.  The link above says something
> about a "sid" repo having the kernel, but I'm not sure how that would affect
> my Lenny system.

indeed you can try the kernel from backports.org or from unstable
they just install fine on testing.
although it might just be a hardware issue of this specific box.

good luck


Reply to: