[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#332942: kernel-image-2.6.8-2-386: fails to insert floppy.ko claiming "io-port 0x03f2 in use"

Martin Michlmayr wrote:
> Version: 2.6.8-99+rm
> You reported a bug against the Linux kernel (version 2.6.8) that was
> shipped with Debian 3.1 (sarge).  Since Debian 3.1 is no longer
> supported and the kernel has changed so much that it would be very
> difficult to verify every outstanding bug from 2.6.8, I'm hereby
> closing your bug report.
> If you still see this issue with the kernel from the upcoming release
> of Debian (lenny, version 5.0), then please me know and I'll be happy
> to reopen this bug report.
> Thanks.

I've just hit this bug on lenny (package linux-image-2.6.26-2-686
version 2.6.26-19lenny2).

To work around the bug and allow loading of the floppy module I needed
to use pnpacpi=off instead of pnpbios=off (I don't know if this is
different due to my hardware having ACPI or due to the kernel).

I've also found that this bug was discussed on the Linux-Kernel
mailing list in Jan/Feb 2009 (see http://lkml.org/lkml/2009/1/31/162 ).
A fix was made and checked into the kernel on 2009-02-18

This patch can be applied to package linux-source-2.6.26 version
2.6.26-19lenny2. Patching produced warnings due other modifications
between 2.6.26 and 2.6.29 as follows
        patching file drivers/block/floppy.c
        Hunk #1 succeeded at 551 (offset -7 lines).
        Hunk #2 succeeded at 4275 (offset -1 lines).
        Hunk #3 succeeded at 4284 (offset -1 lines).
        Hunk #4 succeeded at 4357 (offset -1 lines).
        Hunk #5 succeeded at 4439 (offset -1 lines).
        Hunk #6 succeeded at 4462 (offset -1 lines).
        Hunk #7 succeeded at 4527 (offset -1 lines).
The patched floppy module then loads without needing pnpacpi=off

Reply to: