[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#555102: firmware-ralink not working with 3Com 3CRPCIN175 (RT-2600)

Package: firmware-ralink
Version: 0.14+lenny2

I've got an 3Com 3CRPCIN175 installed but when calling iwconfig no device is listed.
The following dmesg is logged:

[ 14.875549] ACPI: PCI Interrupt 0000:02:0c.0[A] -> GSI 20 (level, low) -> IRQ 20 [ 14.882920] phy0 -> rt61pci_init_eeprom: Error - Invalid RF chipset detected. [ 14.882966] phy0 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
[   14.883024] ACPI: PCI interrupt for device 0000:02:0c.0 disabled

lspci reports:
02:0c.0 Unclassified device [0080]: RaLink RT2600 802.11 MIMO

Please send the output of:
    lspci -vv -n -d 1814:
debian-server:~# lspci -vv -n -d 1814:
02:0c.0 0080: 1814:0401
       Subsystem: 1814:2860
Control: I/O+ Mem+ BusMaster- SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx- Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=slow >TAbort- <TAbort- <MAbort- >SERR- <PERR+ INTx-
       Interrupt: pin A routed to IRQ 20
       Region 0: Memory at f4800000 (32-bit, non-prefetchable) [size=64K]
       Capabilities: [40] Power Management version 3
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
               Status: D0 PME-Enable- DSel=0 DScale=0 PME-
       Kernel modules: rt61pci


hence I suspect that the firmware-ralink should be the correct driver for this device and it ought to work with the 3Com card.

Actually, firmware-ralink contains firmware, not a driver.  The driver
(rt61pci) is part of the kernel package.
Oh u'r absolutely right of course. :-) Thanks for reassigning the bug to the proper package.

I've also tested the latest testing build of firmware-ralink (version 0.18) which reports the same dmesg.

kernel: debian-server 2.6.26-2-686
(also tested with latest testing kernel: 2.6.30-2-686)
Please also test 2.6.31-trunk-686 from experimental (this is meant to be
in unstable now, but there is a delay in adding new binary packages to
I've been trying for an hour now getting the kernel from experimental but failed. I've tried adding the following entry to the sources.list file, but aptitude could not find any 2.6.31 version.
   deb http://ftp.debian.org/debian/ experimental main contrib non-free
I don't see any listed kernel in http://packages.debian.org/experimental/kernel/ either.

I've also tried manually building the latest driver version available at the ralink page:
RT2501PCI/mPCI/CB(RT61:RT2561/RT2561S/RT2661) - 01/23/2009 -
When using this driver, the card showed up iwconfig.


Reply to: