[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#533885: Stops booting with message that it cannot load av7110/bootcode.bin

On 13/07/09 00:30, Ben Hutchings wrote:
> On Sun, 2009-07-12 at 18:45 +0200, Laurent Grawet wrote:
>> Package: linux-image-2.6.30-1-amd64
>> Followup-For: Bug #533885
>> Hello,
>> Hum, I tried vanilla kernel and got the same problem + multiple
>> "BUG: soft lockup - CPU#0 stuck for 61s! [work_for_cpu:2730]"
>> These lockups are related to the inability to load av7110/bootcode.bin.
>> I used make-kpkg to build kernel with firmware compiled INSIDE kernel.
>> So it looks more like a bug from the av7110 driver.
> You can only build firmware inside the kernel if you also build the
> corresponding driver inside the kernel (i.e. not as a module).  Module
> loading and firmware loading go hand-in-hand.

I was sure I was missing something ;-)

> Anyway, Debian kernel
> packages are not built this way, so this is irrelevant.

Of course, I did it that way to do some testing because of the problem.

>> Then I tried to compile kernel with firmware OUTSIDE kernel. I got the
>> same error until I decided to do :
>>     # cp -r /lib/firmware/ /lib/firmware
>> and it worked (+ no more lockups) !
>> So it seems there is a problem with av7110 and firmware compiled in +
>> path problem with firmware outside kernel.
> The version of the Debian-packaged kernel is 2.6.30-1-amd64, not

I just wanted to add more information based on my experiments. I forgot
to mention I also rebuilt 2.6.30-1 from Sid as fist step, then tried the
corresponding bpo kernel, then vanilla 2.6.30 and got exactly the same

With kernel-package, #492516 is likely to be the source of the problem.
With Debian-packaged kernel, it seems bootcode.bin is not part of any
package. Anyway, there shouldn't be lockups when missing firmware.



Reply to: