[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#523828: linux-image-2.6.26-2-486: fails to find modules.pcimap

maximilian attems schrieb:
> On Sun, Apr 12, 2009 at 09:37:51PM +0200, Beat Bolli wrote:
>> Package: linux-image-2.6.26-2-486
>> Version: 2.6.26-15
>> Severity: grave
>> Justification: renders package unusable
>> During installation of the latest 2.6 kernel I get the following:
>> Setting up linux-image-2.6.26-2-486 (2.6.26-15) ...
>> Running depmod.
>> Running mkinitrd.yaird.
>> yaird error: can't open pci module list /lib/modules/2.6.26-2-486/modules.pcimap (fatal)
>> mkinitrd.yaird failed to create initrd image.
>> Failed to create initrd image.
>> dpkg: error processing linux-image-2.6.26-2-486 (--configure):
>>  subprocess post-installation script returned error exit status 9
>> A second "aptitude full-upgrade" produces the same messages.
> well you are using the wrong tool it seems.

So why does the kernel depend on a broken tool? (only half-joking...)

> apt-get install initramfs-tools

OK, after this, the kernel can be configured.

> and post the output of cat /etc/kernel-img.conf

---- snip
link_in_boot = Yes
do_initrd = Yes
---- snap

/boot looks fine to me.

Thanks for your help!


mail: echo '<bNbolOli@ewaSPnetAM.ch>' | tr -d '[A-S]'
pgp: 0x506A903A; 49D5 794A EA77 F907 764F  D89E 304B 93CF 506A 903A
icbm: 47.0452 N, 7.2715 E

"It takes love over gold, and mind over matter" -- Dire Straits

Attachment: signature.asc
Description: OpenPGP digital signature

Reply to: