[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#520891: general: Data coruption on my /dev/sda - /dev/sdd sata_siil siil 3114 chip



On Mon, Mar 23, 2009 at 08:21:54PM +0100, Bengt Samuelsson wrote:
>
>
> dann frazier skrev:
>> On Mon, Mar 23, 2009 at 06:26:52PM +0100, Bengt Samuelsson wrote:
>>   
>>>
>>> dann frazier skrev:
>>>     
>>>> On Mon, Mar 23, 2009 at 04:55:53PM +0100, Bengt Samuelsson wrote:
>>>>         
>>>>> I will be verry happy to ansver every question you may have.
>>>>> It is an old problem I am not able to solve myself.
>>>>>             
>>>> What evidence do you have that corruption is taking place?
>>>>         
>>> Like just uploaded files, ( thru Windows XP Pro - Samba server ) are ok 
>>> day #1 the next day they are corrupted.
>>> Install files don?t work, images locks funny, and like that.
>>> Allmost all files on theese are corrupt now.
>>>
>>> I had almost the same problem during my trying to get RAID5 to work. md0 
>>> vas /dev/sda1 to /dev/sdd1
>>>     
>>
>> What are the contents of /proc/mdstat? Have you fsck'd the filesystem?
>>   
> /proc/mdstat don?t exist, I am not using RAID anymore,
> yes I have run fsck.ext3 -v -y /dev/md0 during the time I tryed RAID5
> /sys/module/sata_sil/parametes/slow_down = 1       I set this!
> /sys/module/sata_sil/version = 2.0
>
> Is there any more 'config' for sata_siil ?

Unfortunately, I don't see any fixes for such a problem upstream, but
that doesn't mean there isn't one. I'd suggest trying our latest
upstream snapshot to see if it behaves better. See
http://wiki.debian.org/DebianKernel for information on obtaining
snapshot builds of the trunk.

If the issue persists, then I strongly recommend reporting to upstream
at http://bugzilla.kernel.org. If you file a bug there, please drop a
note in this report as well so that we can track the status.


-- 
dann frazier




Reply to: