[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#516382: linux-image-2.6.26-1-alpha-generic: tg3: incoming ssh fails with "Corrupted MAC on input"



Package: linux-image-2.6.26-1-alpha-generic
Version: 2.6.26-13
Severity: important

Hi,

After upgrading from etch to lenny, and booting the new kernel, I realized I couldn't login into the box anymore: ssh would consistently fail to connect with:

Corrupted MAC on input

It's reproducible across reboots. When I rebooted into 2.6.18, the problem vanished. I'm using a BCM 5701 (tg3 driver) GigE NIC.

Here's dmesg output with 2.6.18.dfsg.1-24:
tg3.c:v3.65 (August 07, 2006)
eth2: Tigon3 [partno(A6825-60101) rev 0105 PHY(5701)] (PCI:33MHz:64-bit) 10/100/1000BaseT Ethernet 00:30:6e:49:c6:f0
eth2: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] Split[0] WireSpeed[1] TSOcap[0] 
eth2: dma_rwctrl[76ff1b0f] dma_mask[64-bit]

And now with 2.6.26-13:
eth2: Tigon3 [partno(A6825-60101) rev 0105 PHY(5701)] (PCI:33MHz:64-bit) 10/100/1000Base-T Ethernet 00:30:6e:49:c6:f0
eth2: RXcsums[1] LinkChgREG[0] MIirq[0] ASF[0] WireSpeed[1] TSOcap[0]
eth2: dma_rwctrl[76ff1b0f] dma_mask[64-bit]

I can't find anything special in the logs or dmesg, afaict.

HTH

-- System Information:
Debian Release: 5.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: alpha

Kernel: Linux 2.6.18-6-alpha-generic
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.26-1-alpha-generic depends on:
ii  debconf [debconf-2.0]         1.5.24     Debian configuration management sy
ii  initramfs-tools [linux-initra 0.92o      tools for generating an initramfs
ii  module-init-tools             3.4-1      tools for managing Linux kernel mo

linux-image-2.6.26-1-alpha-generic recommends no packages.

Versions of packages linux-image-2.6.26-1-alpha-generic suggests:
ii  aboot                  1.0~pre20040408-3 Linux bootloader for the SRM conso
pn  fdutils                <none>            (no description available)
pn  linux-doc-2.6.26       <none>            (no description available)

-- debconf information:
  linux-image-2.6.26-1-alpha-generic/prerm/would-invalidate-boot-loader-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/postinst/depmod-error-initrd-2.6.26-1-alpha-generic: false
  linux-image-2.6.26-1-alpha-generic/preinst/initrd-2.6.26-1-alpha-generic:
  shared/kernel-image/really-run-bootloader: true
  linux-image-2.6.26-1-alpha-generic/postinst/create-kimage-link-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/postinst/old-initrd-link-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/postinst/depmod-error-2.6.26-1-alpha-generic: false
  linux-image-2.6.26-1-alpha-generic/postinst/bootloader-test-error-2.6.26-1-alpha-generic:
  linux-image-2.6.26-1-alpha-generic/preinst/abort-install-2.6.26-1-alpha-generic:
  linux-image-2.6.26-1-alpha-generic/preinst/elilo-initrd-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/preinst/overwriting-modules-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/preinst/bootloader-initrd-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/preinst/failed-to-move-modules-2.6.26-1-alpha-generic:
  linux-image-2.6.26-1-alpha-generic/postinst/kimage-is-a-directory:
  linux-image-2.6.26-1-alpha-generic/postinst/old-system-map-link-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/postinst/bootloader-error-2.6.26-1-alpha-generic:
  linux-image-2.6.26-1-alpha-generic/postinst/old-dir-initrd-link-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/preinst/lilo-initrd-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/prerm/removing-running-kernel-2.6.26-1-alpha-generic: true
  linux-image-2.6.26-1-alpha-generic/preinst/lilo-has-ramdisk:
  linux-image-2.6.26-1-alpha-generic/preinst/abort-overwrite-2.6.26-1-alpha-generic:
  linux-image-2.6.26-1-alpha-generic/preinst/already-running-this-2.6.26-1-alpha-generic:



Reply to: