[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#509613: Kernel Compile

Hi there,

I'm now ready set to compile a kernel and patch it with the upstream patches. However, last time I compiled a kernel myself, was before the days of make-kpkg - and it's not to compile any kernel, but the official one.

This is the best guess I tried after stress-testing google for some hours and suffering lots of unsuccessful attempts:

rm -Rf linux-2.6-2.6.26; apt-get source -t testing linux-2.6
cd linux-2.6-2.6.26; make-kpkg --added_patches=openvz clean
# get the config from the node into the container ...
scp root@asgard:/boot/config-2.6.26-1-openvz-amd64 .config
make-kpkg --append_to_version=-1-openvz --revision=1 --initrd --rootcmd fakeroot -uc -ua buildpackage

[answer all of the remaining configure questions by <CR>]

This finally generates kernel packages. But I'm still not sure, whether these are the correct ones. Can you confirm that this is the right way to build the kernel packages? Otherwise, what am I doing wrong?

- lars.

Reply to: