[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#434904: marked as done (linux-image-2.6.22-1-sparc64: sbus drivers not autoloaded, boot fails)

Your message dated Sat, 13 Sep 2008 22:38:47 +0200
with message-id <20080913203847.GE7290@wavehammer.waldi.eu.org>
and subject line Uses OF matches
has caused the Debian Bug report #434904,
regarding linux-image-2.6.22-1-sparc64: sbus drivers not autoloaded, boot fails
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

434904: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=434904
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Subject: linux-image-2.6.22-1-sparc64: sbus drivers not autoloaded, boot fails
Package: linux-image-2.6.22-1-sparc64
Version: 2.6.22-2
Severity: important

*** Please type your report below this line ***
I upgraded linux-image-2.6.21-1-sparc64 to 2.6.22-1-sparc64 on my SBus-only
Sun Ultra 1. It appears that sbus driver autoloading is not working (may be a
problem with discover, udev or something other like that). However, due to this
problem, the drivers on initramfs are not autoloaded either and so sun_esp is not
loaded and my root disk does not become visible and boot fails.

Rerunning mkinitramfs -k shows that the module files are present on initramfs and
just the loading is broken.

-- System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: sparc (sparc64)

Kernel: Linux 2.6.21-1-sparc64
Locale: LANG=et_EE.ISO-8859-15, LC_CTYPE=et_EE.ISO-8859-15 (charmap=ISO-8859-15)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.22-1-sparc64 depends on:
ii  coreutils                    5.97-5.3    The GNU core utilities
ii  debconf [debconf-2.0]        1.5.14      Debian configuration management sy
ii  initramfs-tools [linux-initr 0.89        tools for generating an initramfs
ii  module-init-tools            3.3-pre11-4 tools for managing Linux kernel mo
ii  yaird [linux-initramfs-tool] 0.0.12-20   Yet Another mkInitRD

linux-image-2.6.22-1-sparc64 recommends no packages.

-- debconf information:
  linux-image-2.6.22-1-sparc64/postinst/old-dir-initrd-link-2.6.22-1-sparc64: true
  shared/kernel-image/really-run-bootloader: true
  linux-image-2.6.22-1-sparc64/postinst/depmod-error-initrd-2.6.22-1-sparc64: false
  linux-image-2.6.22-1-sparc64/preinst/lilo-initrd-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/preinst/elilo-initrd-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/postinst/old-initrd-link-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/postinst/old-system-map-link-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/prerm/would-invalidate-boot-loader-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/postinst/create-kimage-link-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/preinst/overwriting-modules-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/preinst/bootloader-initrd-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/prerm/removing-running-kernel-2.6.22-1-sparc64: true
  linux-image-2.6.22-1-sparc64/postinst/depmod-error-2.6.22-1-sparc64: false

--- End Message ---
--- Begin Message ---
SBus drivers are looked up via OF matches by modprobe, assume fixed.


Earth -- mother of the most beautiful women in the universe.
		-- Apollo, "Who Mourns for Adonais?" stardate 3468.1

--- End Message ---

Reply to: