[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#498472: linux-image-2.6.26-1-xen-686: does not boot under Etch Xen

On Wed, 2008-09-10 at 12:57 +0200, Ferenc Wagner wrote:
> Ian Campbell <ijc@hellion.org.uk> writes:
> > On Wed, 2008-09-10 at 11:01 +0200, Ferenc Wagner wrote:
> >> [    0.080644] EIP is at xen_write_cr4+0x2/0x6
> >
> > Unfortunately the 3.0.3 hypervisor is stricter in what it will allow CR4
> > to be set to than necessary and won't allow some of the fields which
> > newer kernels use. I think we are unlikely to fix this in the kernel in
> > Debian. You could ask upstream but I'm not sure they would want/be able
> > to change this behaviour.
> Hi Ian,
> thanks for the quick and very informative response!  Is it enough if I
> upgrade to 3.2.0-3~bpo4+2 or should I go for 3.2.1-2 in Lenny?

I don't recall when the relaxation of cr4 changes happened. Newer is
normally better ( ;-) ) but 3.2.0 is probably worth a go if you have an
aversion to 3.2.1.

> Interesting, though, that a CR flag changed going from rc8 to final...

it was probably side effect of an otherwise innocent looking change...

Ian Campbell

BOFH excuse #87:

Password is too complex to decrypt

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: