[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#484565: /lib/modules/2.6.24-1-amd64/kernel/drivers/input/mouse/psmouse.ko: Patch to enable Dell 1420 touch pad's scroll is not working

Package: linux-image-2.6.24-1-amd64
Version: 2.6.24-7
Severity: normal
File: /lib/modules/2.6.24-1-amd64/kernel/drivers/input/mouse/psmouse.ko

*** Please type your report below this line ***
As noticed in bug report #452752
(http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=452752) there was a
need to patch the file drivers/input/mouse/alps.c in order to make the
touch pad's scroll work in some laptops.

At that time it was said that the patch was going to be included in the
2.6.24 kernel.

I installed Debian Lenny in a new Dell 1420 and after installation
upgraded the kernel to 2.6.24-1-amd64 but the touch pad's scroll does not
work. So I downloaded the kernel source to apply the patch that was
working in another Dell inspiron 1420 with kernel 2.6.22 and noticed that the
patch was already applied but with a small change.

In the current 2.6.24 source the patched line (line 36) says:

{ { 0x73, 0x02, 0x50 }, 0xcf, 0xcf, ALPS_FW_BK_1 } /* Dell Vostro 1400

However the patch I was applying to 2.6.22 says:

{ { 0x73, 0x02, 0x50 }, 0x4f, 0x4f, ALPS_FW_BK_1 } /* Dell Vostro 1400

So I changed it, recompiled and reinstalled the mouse drivers, but the
scroll still doesn't work.

Then I upgraded the kernel to 2.6.25-2-amd64 but the scroll didn't work

P.D.: Please don't pay attention to the "hardy" entry in "APT policy" it appears because of a repository I must add in order to install wxFormBuilder, there is no Debian package for that, but that repository only has the wxFormBuilder package.

-- Package-specific info:

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (900, 'testing'), (800, 'unstable'), (500, 'hardy')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.25-2-amd64 (SMP w/2 CPU cores)
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Versions of packages linux-image-2.6.24-1-amd64 depends on:
ii  debconf [debconf-2.0]         1.5.22     Debian configuration management sy
ii  initramfs-tools [linux-initra 0.92a      tools for generating an initramfs
ii  module-init-tools             3.4-1      tools for managing Linux kernel mo

linux-image-2.6.24-1-amd64 recommends no packages.

-- debconf information:
  shared/kernel-image/really-run-bootloader: true
  linux-image-2.6.24-1-amd64/postinst/old-dir-initrd-link-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/preinst/lilo-initrd-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/postinst/create-kimage-link-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/postinst/depmod-error-initrd-2.6.24-1-amd64: false
  linux-image-2.6.24-1-amd64/postinst/old-system-map-link-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/preinst/overwriting-modules-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/postinst/old-initrd-link-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/preinst/bootloader-initrd-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/prerm/would-invalidate-boot-loader-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/prerm/removing-running-kernel-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/preinst/elilo-initrd-2.6.24-1-amd64: true
  linux-image-2.6.24-1-amd64/postinst/depmod-error-2.6.24-1-amd64: false

Jaime Alberto Silva
Ingeniero Electricista
Reply to: