[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#479018: linux-image-2.6.24-1-xen-686: update-grub doesn't recognize vmlinuz-2.6.24-1-xen-686 or vmlinuz-2.6.25-1-xen-686

maximilian attems wrote:
> On Fri, 02 May 2008, Jozef Kutej wrote:
> can you please try out the upcoming 2.6.25-2 package,
> should be available next days.

Setting up linux-image-2.6.25-2-xen-686 (2.6.25-2) ...
update-initramfs: Generating /boot/initrd.img-2.6.25-2-xen-686
Searching for GRUB installation directory ... found: /boot/grub
Searching for default file ... found: /boot/grub/default
Testing for an existing GRUB menu.lst file ... found: /boot/grub/menu.lst
Searching for splash image ... none found, skipping ...
Found Xen hypervisor 3.2-1-i386,  kernel: //vmlinuz-2.6.18-6-xen-686
Found kernel: //vmlinuz-2.6.24-1-686
Found kernel: //vmlinuz-2.6.22-3-686
Found kernel: //memtest86.bin
Updating /boot/grub/menu.lst ... done

So the 2.6.25-2-xen-686 kernel was not added to the menu.lst automatically. By
"hand" I tried first:

title           Xen 3.2-1-i386 / Debian GNU/Linux, kernel 2.6.25-2-xen-686
root            (hd0,0)
kernel          //xen-3.2-1-i386.gz
module          //vmlinuz-2.6.25-2-xen-686 root=/dev/mapper/vg00-root ro
module          //initrd.img-2.6.25-2-xen-686

It started to boot but froze after:

(XEN) Xen is relinquishing VGA console.

Then I tried:

title		Debian GNU/Linux, kernel 2.6.25-2-xen-686
root		(hd0,0)
kernel		//vmlinuz-2.6.25-2-xen-686 root=/dev/mapper/vg00-root ro console=tty0
initrd		//initrd.img-2.6.25-2-xen-686

but that returned:

Error 13: Invalid or unsupported executable format.


Reply to: