[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#476120: linux-2.6: please set CONFIG_X86_BIGSMP



Package: linux-2.6
Severity: normal

Hi,

on a recent intel quad-core (core2) CPU, CONFIG_X86_BIGSMP=y is needed
to boot with more than 8 cpu.

Without it, booting stops after CPU detection. Booting works when
setting maxcpus=8 as boot parameter (but, obviously, you are then
limited to 8 cores).

Quadri Quad-core systems becomes more and more widespread these days
(think virtualization), making x86 machines with more than 8 CPUs more
common. Debian (be it Etch or Lenny) won't work on them.

Please, enable this option, so that debian can be used for a high-end
virtualization system without recompiling !

Backporting this to Etch as well seems mostly harmless to me, but I'll
let a kernel guru check ;)

Cheers,

Clément Hermann (nodens)

-- (Irrelevant) System Information:
Debian Release: lenny/sid
  APT prefers unstable
  APT policy: (990, 'unstable'), (1, 'experimental')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.24-1-amd64 (SMP w/1 CPU core)
Locale: LANG=fr_FR.UTF-8, LC_CTYPE=fr_FR.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash



Reply to: