[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#463498: udev leftovers/ master mode

On Sun, Mar 09, 2008 at 08:15:00AM +0100, thomas schorpp wrote:
> Kurt Roeckx wrote:
>> On Sat, Feb 23, 2008 at 09:10:39PM +0100, thomas schorpp wrote:
>>> confirmed or the doc is outdated, udev is not involved in issues, 
>>> just clean up z25_persistent-net.rules, managed mode with RSN EAP-PSK 
>>> fine but master mode not selectable here with ucode5.fw:
>> My problem was actually related to udev.  After removing the line from
>> the /etc/udev/rules.d/z25_persistent-net.rules file, it booted properly.
>> I had this in it:
>> SUBSYSTEM=="net", DRIVERS=="?*", ATTRS{address}=="00:0f:66:c6:91:12", NAME="eth3"
>> And udev now added:
>> SUBSYSTEM=="net", DRIVERS=="?*", ATTR{address}=="00:0f:66:c6:91:12", ATTR{type}=="1", NAME="wlan0"
>> And it seems the kernel get confused when I tried to talk to wmaster0 as
>> if it were wlan0.
>> Anyway, if you have a different problem, I think then atleast 465775
>> should get reassigned to udev.
>> Kurt
> well master mode is not available at this time due to upstream wireless stack limitations.

I'm not using master mode, and that is not my problem.  My problem is
that my interface (wlan0) doesn't properly get renamed to eth3, and it
ends up as wlan0_rename.

They way I see it you had two problems:
- The renaming didn't work properly, but you've solved that by
  "cleaning up" the udev files.  That worked for all of us.
- Master mode doesn't work.

Both bug reports were really only about the first issue.  Which is
why I suggested that we reassign the other bug report to udev.

> for udev i've said "clean up" and not "add something". without Your addition it will work.

Clean up was removing the old line that renamed wmaster0 to eth3 and
then failed to rename wlan0 to eth3 and got me wlan0_rename.  udev
itself added the new line.

> this cannot be done automatically since b43 is not bcm43xxx for udev. how should it know?

There is nothing in there that says it's either b43 or bcm43xxx.  Any
driver that gives that MAC address should do.  I don't see why this
should cause a problem.

> and _never_ add manually created stuff to (partly) autogenerated config files in ".d" directories!

I did not add anything, I removed something.  But those are config files:
if things aren't working the way you want them, you _can_ edit them.

eth3 was previously added to that config file by udev itself.

> and you cannot "talk" to wmaster0, this is just a driver internal device 
> without wexts like madwifi's wifi0.

The problem is that wmaster0 got renamed to eth3.  During boot it tried
to do "ifup eth3" , so basicly "ifup wmaster0=eth3".  udev should have
renamed wlan0 to eth3 instead and things would have worked.

Once the scripts have tried to do the ifup on wmaster0/eth3, things seem
to break and doing "ifup wlan0_rename=eth3" doesn't work anymore.  This
might be for instance because ifup tried to assign a static ip address
to wmaster0/eth3.


Reply to: