[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#465901: [PATCH] 465901 (cryptroot remote unlocking on boot feature)



On Fri, 15 Feb 2008, debian@x.ray.net wrote:

> From: <debian@x.ray.net>
> 

ok read the description from the other mail,
for quicker response description above patch helps :)
> ---
>  mkinitramfs       |    1 +
>  scripts/functions |   63 +++++++++++++++++++++++++++-------------------------
>  2 files changed, 34 insertions(+), 30 deletions(-)
> 
> diff --git a/mkinitramfs b/mkinitramfs
> index 06d2149..13219af 100755
> --- a/mkinitramfs
> +++ b/mkinitramfs
> @@ -168,6 +168,7 @@ DPKG_ARCH=`dpkg --print-installation-architecture`
>  
>  # Export environment for hook scripts.
>  #
> +export CONFDIR
>  export MODULESDIR
>  export version
>  export CONFDIR

why should it be exported twice?

> diff --git a/scripts/functions b/scripts/functions
> index fdd808f..bbfb2b8 100644
> --- a/scripts/functions
> +++ b/scripts/functions
> @@ -273,35 +273,38 @@ parse_numeric() {
>  
>  configure_networking()
>  {
> -	# support ip options see linux sources Documentation/nfsroot.txt
> -	case ${IPOPTS} in
> -	none|off)
> -		# Do nothing
> -		;;
> -	""|on|any)
> -		# Bring up device
> -		ipconfig ${DEVICE}
> -		;;
> -	dhcp|bootp|rarp|both)
> -		ipconfig -c ${IPOPTS} -d ${DEVICE}
> -		;;
> -	*)
> -		ipconfig -d $IPOPTS
> -
> -		# grab device entry from ip option
> -		NEW_DEVICE=${IPOPTS#*:*:*:*:*:*}
> -		if [ "${NEW_DEVICE}" != "${IPOPTS}" ]; then
> -			NEW_DEVICE=${NEW_DEVICE%:*}
> -		else
> -			# wrong parse, possibly only a partial string
> -			NEW_DEVICE=
> -		fi
> -		if [ -n "${NEW_DEVICE}" ]; then
> -			DEVICE="${NEW_DEVICE}"
> -		fi
> -		;;
> -	esac
> +	if [ ! -e /tmp/net-${DEVICE}.conf ]; then

i prefer the more readable version at the start of the function:

# networking already configured thus bail out
[ -e /tmp/net-${DEVICE}.conf ] && return 0

care to resend that hook?



Reply to: