[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#279681: marked as done (serious problem with "Host Protected Area")



Your message dated Sat, 5 Jan 2008 22:02:23 +0100
with message-id <20080105210223.GM17624@stro.at>
and subject line serious problem with "Host Protected Area"
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: installation-reports

Debian-installer-version: sarge-i386-netinst.iso (daily 3.11.2004) from debian.de

uname -a:
	Linux (none) 2.6.8-1-386 #1 Thu Oct 7 02:21:16 EDT 2004 i686 unknown
Date: 4.11.2004 3pm
Method: Boot from CD

Machine: Gericom EGO MS1003 (Centrino-Notebook)
Processor: Pentium M (Banias) 1,5 Ghz
Memory: 512MB DDR
Root Device: hda (IDE)
Root Size/partition table:
	That's part of the problem	
Output of lspci and lspci -n:
	can't get it right now, but it has centrino chipset
	ide controller is piix, I think.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O] (onboard ethernet, no WLAN)
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]

Comments/Problems:

The Notebook comes with Phoenix's cME (core Management Environment) which uses a Host Protected Area of 10GB on the Harddisk. (Fujitsu MHS2060AT 60GB). I don't want to use the Phoenix Recovery feature (for which the reserved 10GB are meant to be used) and the HPA but cannot turn it off in the BIOS. Knoppix discovers the full capacity of the drive and allows me to create partitions, filesystems in the HPA. di currently doesn't.

dmesg after Knoppix boot (V3.4, Kernel 2.4.23-xfs) tells me:

--snip--
hda: Host Protected Area detected.
	current capacity is 104041314 sectors (53269 MB)
	native  capacity is 117210240 sectors (60011 MB)
hda: Host Protected Area disabled
hda: 117210240 sectors (60011 MB) [...]
--snap--

whereas dmesg on a shell during the di-setup tells me:
--snip--
hda: Host Protected Area detected.
	current capacity is 104041314 sectors (53269 MB)
	native  capacity is 117210240 sectors (60011 MB)
hda: 104041314 sectors (53269 MB) [...]
--snap--

obviously the default behaviour of how to treat the HPA-"feature" differs between the knoppix and the di kernel.

Unfortunately I was not able to get the di kernel to disable the HPA, too. I tried the following boot parameters:

hd=7296,255,63 (which is the "native" geometry reported by fdisk on knoppix)

hda=stroke (which after looking at the source of the current ide-driver should disable HPA, I think)

hda=noprobe hda=stroke hda=7296,255,63

but nothing works. I have the feeling that these options aren't even passed to the ide-driver which is loaded after the 3 language settings during setup are configured.

I tried to load the ide-generic module from a shell, before di loads it with
	modprobe ide-generic hda=stroke

and some other options as mentioned above.

but all of that has no effect. di still recognizes the drive as 53.something GB and does not allow me to install into the last 10GB of the disk.

(btw. removing the ide-driver at this stage with modprobe -r ide-generic causes a segfault in the kernel! That's pretty ugly even if the ide module is not to be expected to be removed, anyway. While experimenting I had to do several reboots because of that.)

I tried to shrink my XP-Partition and install debian into the "official" disk-space, but this causes an even more severe problem. In that case the installation goes very well at first. Everything is copied and GRUB is installed into the MBR. But after the reboot GRUB says (approximately from my memory):

GRUB stage 1.5
<like 2 seconds pause>
loading GRUB, please wait...

And nothing happens. Not even an error message. I can only hard-reset.
Probably GRUB gets confused with the 2 drive geometries (thanks to HPA) and can't access the stage2? I have booted knoppix, mounted and chrooted the debian partition and rerun grub-install: No effect. The problem then was that the Windows XP-CD didn't boot after that for some reason(black screen after scanning hardware and the disk LED flashing for a splitsecond) which would have allowed me to reinstall the Windows-MBR.

-> I had to completely reinstall XP after zeroing out the MBR!!!

So, since it can be expected that more and more notebooks will be built with this nice HPA/cME-"feature" (I didn't know about it when I bought the notebook and had to do some googling) this should really be given some thought, I guess. What about a boot switch that disables HPA? It is obviously possible to safely just ignore it if the user doesn't want to use the cME features. I have done that with knoppix and successfully created a filesystem in that area of the disk and stored some gigs of data there. The partition survived reboots but is not accessible with anything else but Knoppix. :-(

Apart from that: di is great work! Keep going. I'm a real debian-fan but the old install system really was a pain. di is awesome. Thank you so much!

cheers,
-Marvin




--- End Message ---
--- Begin Message ---
Version: 2.6.18-1

closing as no response since initial report and ping.
also most likely fixed due to ide driver fixes.

-- 
maks


--- End Message ---

Reply to: