[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#448314: linux-source-2.6.22: "make-kpkg clean" exits with Error 2

Package: linux-source-2.6.22
Version: 2.6.22-4~bpo40+1
Severity: normal

It looks like the "debian" subdirectory is being deleted too soon.


CH:/usr/src/linux-current# make-kpkg clean
exec debian/rules DEBIAN_REVISION=5:10.Custom clean

====== making target CLN-common [new prereqs: testdir]======

====== making target CLN-common [new prereqs: ]======
/usr/bin/make -f ./debian/rules real_stamp_clean
make[1]: Entering directory `/usr/src/linux-source-2.6.22'
====== making target real_stamp_clean [new prereqs: ]======
running clean
test ! -f scripts/package/builddeb.kpkg-dist ||           \
mv -f scripts/package/builddeb.kpkg-dist scripts/package/builddeb
test ! -f scripts/package/Makefile.kpkg-dist ||           \
mv -f scripts/package/Makefile.kpkg-dist scripts/package/Makefile
test ! -f .config || cp -pf .config config.precious
test ! -f Makefile || \
/usr/bin/make  ARCH=i386 distclean
make[2]: Entering directory `/usr/src/linux-source-2.6.22'
CLEAN  scripts/basic
CLEAN  scripts/kconfig
CLEAN  /usr/src/linux-source-2.6.22/debian/
CLEAN  include/config
CLEAN  .config include/linux/autoconf.h
make[2]: Leaving directory `/usr/src/linux-source-2.6.22'
test ! -f config.precious || mv -f config.precious .config
/usr/bin/make -f ./debian/rules unpatch_now
make[2]: Entering directory `/usr/src/linux-source-2.6.22'
make[2]: ./debian/rules: No such file or directory
make[2]: *** No rule to make target `./debian/rules'. Stop.
make[2]: Leaving directory `/usr/src/linux-source-2.6.22'
make[1]: *** [real_stamp_clean] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.22'
make: *** [CLN-common] Error 2

-- System Information:
Debian Release: 4.0
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux
Locale: LANG=C, LC_CTYPE=C (charmap=ANSI_X3.4-1968)

Versions of packages linux-source-2.6.22 depends on:
ii  binutils                      2.17-3     The GNU assembler, linker and bina
ii  bzip2                         1.0.3-6    high-quality block-sorting file co

Versions of packages linux-source-2.6.22 recommends:
ii  gcc                    4:4.1.1-15        The GNU C compiler
ii  libc6-dev [libc-dev]   2.3.6.ds1-13etch2 GNU C Library: Development Librari
ii  make                   3.81-2            The GNU version of the "make" util

-- no debconf information

Reply to: