[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#439072: snd-intel8x0 line-in not working in later 2.6.x kernels

Package: linux-2.6


I'm reporting this bug that I have been seeing for a while and which is
a regression from a few months/years ago - the line-in input simply doesn't
work right. arecord(1) just doesn't record anything with it, it doesn't show
any errors, it records silence. The recording from the same external source
works just fine with the microphone input.

I and apparently many other people noticed the same bug indirectly, by
noticing that the sound input from the TV card isn't working. (Many TV cards
ship with a line-out and a short cable which connects the TV sound output
with the regular sound card input.)

I also tried changing the external sources - I tried to record using a
microphone via the mic in, and that still works just fine, whereas the
microphone via the line in also fails to record anything.
And finally, the TV card is heard just fine when plugged into the mic in.

This works just fine with the same hardware in MS Windows (ugh), and it also
worked fine with an earlier 2.6.x kernel version that I had been using when
I was still running sarge on this machine. But, I removed it in the meantime
so I don't know which one it was. I think it was 2.6.16 or so, but I'm not
sure. It's definitely not working with >= 2.6.18 (I still have one of those
and it behaves the same as 2.6.21).

I have previously recorded my problem in the Ubuntu bug report #29789[1],
which includes a bit of a convoluted description at the beginning which also
talks about an unrelated module, but it appears that several other people
are seeing the same problem as I am.

The Debian bug report #384933 mentions that snd-emu10k1 also has
a dysfunctional line-in.

The bug report #374545 mentions something vaguely similar, but even though
they have an explicit error message there, the suspicious bit was that the
regression happened from .15 to .16, which should be around the same time
as this.

I grepped the kernel patch files for .13, .14, .15, .16, .17, and they
rarely ever mention snd-intel8x0. The "quirks" option was added in .14,
but offhand that doesn't seem to be related to the line-in.
(The snd-emu10k1 driver is even more rarely mentioned in the said patches.)

Any help would be appreciated. TIA.

[1] https://bugs.launchpad.net/ubuntu/+bug/29789

     2. That which causes joy or happiness.

Reply to: