[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#379776: marked as done (e1000: eth0: e1000_clean_tx_irq: Detected Tx Unit Hang)

Your message dated Wed, 8 Aug 2007 11:47:48 +0200
with message-id <20070808094748.GF6137@stro.at>
and subject line e1000: eth0: e1000_clean_tx_irq: Detected Tx Unit Hang
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: linux-image-2.6-686
Version: 2.6.16+0.2
Severity: important


I'm obviousely suffering from the problem described at


Some background information: I tried to install several other
distributions on this Compaq ML 530 machine (well, I was told to
use something else than Debian) and failed (for sure ;-)).  I grabbed
a random Live-CD (Ubuntu 5.10) laying around on my desk which worked.
It was using Kernel 2.6.12.  Now I wanted to give Debian a chance
and etch installers failed as well, while I was lucky with
Sarge RC2 installer.  When upgrading kernel-image to linux-image-2.6-686
the old problem was show: The console was floded with

   kernel: e1000: eth0: e1000_clean_tx_irq: Detected Tx Unit Hang

messages. An  'lspci -v' shows

05:06.0 Ethernet controller: Intel Corporation 82542 Gigabit Ethernet Controller (rev 03)
        Subsystem: Compaq Computer Corporation NC1634 Gigabit Ethernet Adapter (1000-SX)
        Flags: bus master, medium devsel, latency 64, IRQ 201
        Memory at c6fc0000 (32-bit, non-prefetchable) [size=128K]
        Capabilities: <access denied>

My guess is that the driver for this card was changed from
kernel 2.6.12 to 2.6.13 (which shows the first problem reports
when asking Google) and this explains why several other distributions
(using higher than 2.6.12 kernels) failed but Sarge and the
Live-CD worked.

Feel free to contact me in case you need further information


-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.8-3-686
Locale: LANG=de_DE@euro, LC_CTYPE=de_DE@euro (charmap=ISO-8859-15)

Versions of packages linux-image-2.6-686 depends on:
ii  linux-image-2.6.16-2-686      2.6.16-17  Linux kernel 2.6.16 image on PPro/

linux-image-2.6-686 recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 2.6.18-1

report against an _old_ kernel,
no reply on ping.

assumingly fixed.


--- End Message ---

Reply to: