[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#335934: marked as done (linux-source-2.6.13: preemptive kernel (sometimes) doesnt suspend to ram)

Your message dated Fri, 3 Aug 2007 18:05:20 +0200
with message-id <20070803160520.GA28532@stro.at>
and subject line linux-source-2.6.13: preemptive kernel (sometimes) doesnt suspend to ram
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: linux-source-2.6.13
Version: 2.6.13-1
Severity: normal

*** Please type your report below this line ***

I tried compiling a laptop kernel from the linux-source-2.6.13 2.6.13-1.
Unlike the debian precompiled kernel I tried the most agressive
preemption option. The resulting kernel worked for some time, but then I
installed the xfree synaptics driver.
>From then on, the process writing "mem" to the /sys/power/state would
stay in uninterriptible sleep until system shutdown (did not try to go
to runlevel 2 or something like that). Simply restarting X did not help.
A kernel without preemption or X without synaptics driver works.
The machine is an old Dell laptop with BX chipset.

I am not sure if the Debian patches affect this behavior in any way.
I will try to test with a vanilla kernel later.


Michal Suchanek

-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (900, 'testing'), (800, 'stable'), (600, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.12-1-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

--- End Message ---
--- Begin Message ---
Package: linux-2.6
Version: 2.6.18-1

preempt is disabled in etch.
happy suspend.


--- End Message ---

Reply to: