[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#435655: linux-image-2.6.21-2-686: ibm-acpi oops on removal

On Thu, Aug 02, 2007 at 02:45:25PM +0300, George Tellalov wrote:
> Package: linux-image-2.6.21-2-686
> Version: 2.6.21-6
> Severity: important

unstable has a newer kernel,
when reporting kernel bugs please always install the latest available.
it just installs fine in testing.
> ibm-acpi module works fine on this thinkpad but when trying to remove the module I get a kernel oops. The same happens when trying to suspend the machine - probably the suspend is trying to remove the module as well.
> Hardware details:
> sys_vendor   = "IBM"
> sys_product  = "26454AU"
> bios_version = "INET36WW"

i can't reproduce it on 2.6.22:
modprobe thinkpad-acpi

thinkpad_acpi: ThinkPad ACPI Extras v0.14
thinkpad_acpi: http://ibm-acpi.sf.net/
thinkpad_acpi: ThinkPad EC firmware 74HT25WW-1.00
thinkpad_acpi: acpi_bus_get_device(bay) failed: -19
thinkpad_acpi: disabling subdriver bay

rmmod thinkpad-acpi

no oops

there was quite some acpi merge for 2.6.22, aboves test was on a x41.
please report back unless you can reproduce the trouble with it
i'll have to close that report.



Reply to: