[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Bug#434040: libdebian-installer: type declaration conflict



reassign 434040 linux-libc-dev
tags 434040 d-i
thanks

On Saturday 21 July 2007 07:47, Frans Pop wrote:
> While compiling kbd-chooser on sparc64, I got the following errors.
> Looks like there's some conflict with linux-libc-dev (2.6.22-1)?

> In file included from /usr/include/debian-installer/types.h:29,
>                  from /usr/include/debian-installer/exec.h:26,
>                  from /usr/include/debian-installer.h:5,
>                  from ksyms.c:5:
> /usr/include/sys/types.h:62: error: conflicting types for ‘dev_t’
> /usr/include/linux/types.h:13: error: previous declaration of ‘dev_t’ was here
> /usr/include/sys/types.h:67: error: conflicting types for ‘gid_t’
> /usr/include/linux/types.h:27: error: previous declaration of ‘gid_t’ was here
> /usr/include/sys/types.h:72: error: conflicting types for ‘mode_t’
> /usr/include/linux/types.h:15: error: previous declaration of ‘mode_t’ was here
[...]

According to Bastian this is an issue in linux-libc-dev or libc-dev:
<waldi> fjp: its a bug between libc-dev and linux-libc-dev ...
<fjp> waldi: OK. Already reported and being worked on? BR#?
<waldi> the later provides backward-compatible user definitions which
the libc should disable but always do
<waldi> i think about dropping them at once

Attachment: pgp9zDyBegyzG.pgp
Description: PGP signature


Reply to: