[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#421248: marked as done (linux-headers-2.6.20-1-686: does not match linux-image-2.6.20-1-686: nvidia-kernel and vmware driver compilations fail)

Your message dated Sat, 28 Apr 2007 21:35:23 -0400
with message-id <200704282135.23740.chealer@gmail.com>
and subject line Invalid
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: linux-headers-2.6.20-1-686
Version: 2.6.20-3
Severity: important

The headers package is completely useless:

1) nvidia drivers do not work, tried:
build: module-assistant a-i nvidia-kernel
tried installing with "modprobe nvidia", but it refuses to load.
dmesg says module refuses to load because the module disagrees on kernel structures.

2) vmware-config.pl fails with the following:
Unable to make a vmmon module that can be loaded in the running kernel:
insmod: error inserting '/tmp/vmware-config0/vmmon.o': -1 Unknown symbol in module
There is probably a slight difference in the kernel configuration between the
set of C header files you specified and your running kernel.  You may want to
rebuild a kernel based on that directory, or specify another directory.

I checked Google and such problems usually appear when a different version of gcc is used
to compile the kernel and the driver. However this is not the case, as:
# cat /proc/version
Linux version 2.6.20-1-686 (Debian 2.6.20-3) (waldi@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Tue Apr 24 21:52:11 UTC 2007
# gcc --version
gcc (GCC) 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

Then I took linux- from kernel.org, minimized fieatures in .config and 
compiled it with make-kpkg and everything works with my generated image and headers.

So what went wrong with Debian kernel releases?

-- System Information:
Debian Release: lenny/sid
Architecture: i386 (i686)

Kernel: Linux 2.6.20-1-686 (SMP w/1 CPU core)
Locale: LANG=lt_LT.UTF-8, LC_CTYPE=lt_LT.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages linux-headers-2.6.20-1-686 depends on:
ii  gcc-4.1                       4.1.1-21   The GNU C compiler
ii  linux-headers-2.6.20-1        2.6.20-3   Common header files for Linux 2.6.
ii  linux-kbuild-2.6.20           2.6.20-1   Kbuild infrastructure for Linux 2.

linux-headers-2.6.20-1-686 recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
The headers package is usable. The first point you raised is already reported 
in #419943.

Feel free to open a bug report about the second issue if it's valid and not 
already reported.

--- End Message ---

Reply to: