[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#411284: initramfs-tools: Created initramfs fails to evms_activate

severity 411284 wishlist
reassign 411284 cryptsetup

On Sat, 17 Feb 2007, Sami Liedes wrote:

> The created initramfs for some reason seems to fail to activate evms.
> I have a setup where I have evms+lvm2, and an evms-volume
> "root-crypted" is a luks volume of the root file system.

the evms boot script activate your evms if you pass an evms volume.
> This is what happens (typed, not captured from serial console or
> something, so any typos are mine):
> ------------------------------------------------------------
> Begin: Mounting root file system ...
> Begin: Running /scripts/local-top ...
> device-mapper: ioctl: 4.7.0-ioctl (2006-06-24) initialised: dm-devel@redhat.com
>    Volume group "root" not found
> Done.
> Begin: Waiting for root file system...
> ------------------------------------------------------------

sure this is the generic start up.
> I don't know what causes the message about vg "root" to not be found.
> I have no such vg, although it might be that I have have once had
> such.

well maybe evms didn't clear that info..
> Once I get dropped to busybox shell, inspecting /dev reveals there is
> no /dev/evms directory. Running evms_activate from the shell correctly
> creates the directory and the nodes/mappings there, but after that
> fails with
> ------------------------------------------------------------
> libgcc_s.so.1 must be installed for pthread_cancel to work
> Aborted
> ------------------------------------------------------------
> However the nodes and mappings apparently have been correctly created
> before that.
> After that, I run "cryptsetup luksOpen /dev/evms/root-crypted
> root-decrypted" and enter my root filesystem password.
> /dev/mapper/root-decrypted is created. Then typing "exit" allows the
> boot process to continue and finish successfully.

ok so cryptsetup checks afaik if it's on top of lvm2 and activates that.
it should do the same for evms, thus reassigning and
putting evms package maintainer on cc for notice.

thanks for detailed report!
> ------------------------------------------------------------
> Additionally there's something wrong with the busybox shell: ctrl-c
> and ctrl-z do not work in it, so if I issue e.g. the commad "cat" in
> the shell, I'm stuck forever.

hmm well haven't tried to reprodue yet,
but that is an minor busybox bug.
> -- Package-specific info:
> -- /proc/cmdline
> root=/dev/mapper/root-decrypted ro 
> -- /proc/filesystems
> 	cramfs
> 	ext3
> 	ext2
> -- kernel-img.conf
> do_symlinks = yes
> relative_links = yes
> do_bootloader = no
> do_bootfloppy = no
> do_initrd = yes
> link_in_boot = yes
> postinst_hook = /sbin/update-grub
> postrm_hook = /sbin/update-grub

for better grub upgrade change those into
 postinst_hook = update-grub
 postrm_hook = update-grub
best regards


Reply to: