[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#409822: linux-image-2.6.18-4-vserver-686: pcmcia wireless card doesn't work until inserting usb ethernet

Package: linux-image-2.6.18-4-vserver-686
Version: 2.6.18.dfsg.1-10
Severity: normal

so, i've got this old pcmcia wireless card, and the strange thing is
that it doesn't work until i insert a usb ethernet device. i don't know
what could be causing this behavior ... 

from my syslog:

Feb  2 11:10:00 ghig kernel: ADDRCONF(NETDEV_UP): eth0: link is not
Feb  2 11:10:04 ghig kernel: eth0: New link status: Connected (0001)
Feb  2 11:10:04 ghig kernel: ADDRCONF(NETDEV_CHANGE): eth0: link becomes
Feb  2 11:10:04 ghig kernel: usb 1-1: new full speed USB device using
uhci_hcd and address 2
Feb  2 11:10:05 ghig kernel: usb 1-1: configuration #1 chosen from 1
Feb  2 11:10:05 ghig kernel: pegasus: v0.6.13 (2005/11/13),
Pegasus/Pegasus II USB Ethernet driver
Feb  2 11:10:05 ghig kernel: pegasus 1-1:1.0: setup Pegasus II specific
Feb  2 11:10:05 ghig kernel: pegasus 1-1:1.0: eth1, D-Link DSB-650TX,
Feb  2 11:10:05 ghig kernel: usbcore: registered new driver pegasus

if i don't insert the usb ethernet device, i can wait 5-10 hours and
still not get the "ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready"
message. i've tried at least a dozen times over the past couple months,
and it seems reproduceable on my system.

could somehow the link status on the usb ethernet device trigger some
sort of link status event for the pcmcia wireless card?

certainly got me a little confused.

Bus 001 Device 003: ID 2001:400b D-Link Corp. [hex]
Bus 001 Device 001: ID 0000:0000

pccardctl info
PRODID_1="Lucent Technologies"
PRODID_3="Version 01.01"

live well,

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-4-vserver-686
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages linux-image-2.6.18-4-vserver-686 depends on:
ii  coreutils                     5.97-5     The GNU core utilities
ii  debconf [debconf-2.0]         1.5.11     Debian configuration management sy
ii  initramfs-tools [linux-initra 0.85e      tools for generating an initramfs
ii  module-init-tools             3.3-pre3-1 tools for managing Linux kernel mo

Versions of packages linux-image-2.6.18-4-vserver-686 recommends:
ii  libc6-i686                  2.3.6.ds1-10 GNU C Library: Shared libraries [i
ii  util-vserver                0.30.211-6   user-space tools for Linux-VServer

-- debconf information excluded

Reply to: