[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#360478: marked as done (linux-image-2.6.16-1-k7: mount encrypted ide crash)

Your message dated Mon, 22 Jan 2007 11:36:08 +0100
with message-id <20070122103608.GE29435@nancy.stro.at>
and subject line Bug#360478: linux-image-2.6.16-1-k7: mount encrypted ide crash
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: linux-image-2.6.16-1-k7
Version: 2.6.16-4
Severity: important


Since 2.6.16 I experience some crashes when mounting an encrypted ide
partition. Crashes does not always happen but let's say 50% time. If it
shall crash it always happen just when mounting the partition.

Effects are : X or console freeze. Under console, SysRq Sync +
remount may allow to recover the console after some 'sleeping time'
(however no 'DONE' appearing). Later '/sbin/reboot' sometimes hangs and
SysRq reboot is the only way.

In case the console comes back one can save from dmesg:
BUG: soft lockup detected on CPU#0!

Pid: 4199, comm:                mount
EIP: 0060:[<b0130097>] CPU: 0
EIP is at find_get_pages+0x41/0x45
 EFLAGS: 00000246    Not tainted  (2.6.16-1-k7 #1)
EAX: 80000821 EBX: eb11fc80 ECX: eb11fc8c EDX: b17625e0
ESI: 00000001 EDI: 00000001 EBP: 00000001 DS: 007b ES: 007b
CR0: 8005003b CR2: af8d95e4 CR3: 3b954000 CR4: 000006d0
 [<b01357a4>] pagevec_lookup+0x1a/0x21
 [<b013613e>] invalidate_mapping_pages+0x92/0xa7
 [<b0136160>] invalidate_inode_pages+0xd/0x11
 [<b014c707>] kill_bdev+0xb/0x22
 [<b014cdfb>] set_blocksize+0x6f/0x7b
 [<b014ce1d>] sb_set_blocksize+0x16/0x3c
 [<f08d1089>] ext3_fill_super+0x3bd/0x1368 [ext3]
 [<b01a3a36>] snprintf+0x1a/0x1e
 [<b014c495>] get_sb_bdev+0xc5/0x10f
 [<f08cf49f>] ext3_get_sb+0x1a/0x1e [ext3]
 [<f08d0ccc>] ext3_fill_super+0x0/0x1368 [ext3]
 [<b014bca2>] do_kern_mount+0x88/0x12d
 [<b015d428>] do_mount+0x629/0x684
 [<b0152be8>] link_path_walk+0xb0/0xbb
 [<b013a193>] __handle_mm_fault+0x348/0x650
 [<b0152fb3>] do_path_lookup+0x17f/0x19a
 [<b0133b8f>] get_page_from_freelist+0x7e/0x294
 [<b0133df3>] __alloc_pages+0x4e/0x261
 [<b01341c2>] __get_free_pages+0x2f/0x34
 [<b015c27e>] copy_mount_options+0x28/0x10e
 [<b015d4f5>] sys_mount+0x72/0xad
 [<b01028ff>] sysenter_past_esp+0x54/0x75
SysRq : Emergency Sync
SysRq : Emergency Remount R/O

I never experienced such problem with 2.6.15. I booted with 2.6.12 and did
not see the same problem -> seems to come from 2.6.16.

I tried to reproduce it on an encrypted USB stick (to avoid any risk of
hdd corruption resulting from trials), but I couldn't -> seems linked to

I can reproduce it on several different hdd.

FYI encryption comes from: dpkg -l cryptsetup dmsetup
ii  cryptsetup                    1.0.2+1.0.3-rc3-1 configures encrypted block devices
ii  dmsetup                       1.02.03-1         The Linux Kernel Device Mapper userspace library

Kind regards,
Franck R.

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.16-1-k7
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages linux-image-2.6.16-1-k7 depends on:
ii  module-init-tools             3.2.2-2    tools for managing Linux kernel mo
ii  yaird [linux-initramfs-tool]  0.0.12-9   Yet Another mkInitRD

Versions of packages linux-image-2.6.16-1-k7 recommends:
ii  libc6-i686                    2.3.6-4    GNU C Library: Shared libraries [i

-- debconf information:
  linux-image-2.6.16-1-k7/preinst/lilo-initrd-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/preinst/bootloader-initrd-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/postinst/old-initrd-link-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/postinst/depmod-error-2.6.16-1-k7: false
  linux-image-2.6.16-1-k7/prerm/would-invalidate-boot-loader-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/preinst/elilo-initrd-2.6.16-1-k7: true
* linux-image-2.6.16-1-k7/preinst/already-running-this-2.6.16-1-k7:
  linux-image-2.6.16-1-k7/prerm/removing-running-kernel-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/postinst/depmod-error-initrd-2.6.16-1-k7: false
  linux-image-2.6.16-1-k7/postinst/old-dir-initrd-link-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/preinst/overwriting-modules-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/postinst/create-kimage-link-2.6.16-1-k7: true
  linux-image-2.6.16-1-k7/postinst/old-system-map-link-2.6.16-1-k7: true

--- End Message ---
--- Begin Message ---
On Sun, 14 Jan 2007, franckr wrote:

> Hi Maximilian,
> So far I didn't experience any crash, even after several mount-unmount.
> => I believe problem is solved and this bug report can be closed.
> I tested with:
> dpkg -l cryptsetup dmsetup linux-image-2.6.18-3-k7
> ii  cryptsetup                    1.0.4+svn26-1
> ii  dmsetup                       1.02.12-1
> ii  linux-image-2.6.18-3-k7       2.6.18-8
> Regards & Happy new year to you too,
> Franck

ok thanks for the feedback. :)

thus closing


--- End Message ---

Reply to: