[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#400372: dpkg randomly craches on Sparc32 running HyperSPARC processor

Jurij Smakov a écrit :
Hi Joel,

	Hello Jurij,

Sorry, I cannot reproduce the behavior you are describing. I have a SS20 box, running sid with Debian's linux-image-2.6.18-3-sparc32 (version 2.6.18-6) kernel:

I don't try with debian package, only with official linux kernel. I have tested the 2.6.19 but sunlance doesn't work for me in a SS20 that runs with two sunlance (eth0/1)and one hme (eth2) interfaces... I don't know the difference between the debian and official kernels.

debian:~# uname -a
Linux debian 2.6.18-3-sparc32 #1 Fri Nov 24 16:10:16 GMT 2006 sparc GNU/Linux
debian:~# cat /proc/version Linux version 2.6.18-3-sparc32 (Debian 2.6.18-6) (waldi@debian.org) (gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-20)) #1 Fri Nov 24 16:10:16 GMT 2006 debian:~# cat /proc/cpuinfo cpu : ROSS HyperSparc RT625 or RT626
fpu             : ROSS HyperSparc combined IU/FPU
promlib         : Version 3 Revision 2
prom            : 2.25
type            : sun4m
ncpus probed    : 2
ncpus active    : 1
CPU0Bogo        : 133.12
CPU0ClkTck      : 133000000
MMU type        : ROSS HyperSparc
contexts        : 4096
nocache total   : 2252800
nocache used    : 492800

To stress-test dpkg I've just ran 'apt-get install kde' on an unstable system. That a pretty big update:

	Is your kernel SMP ? Do you use HIGHMEM ?

0 upgraded, 400 newly installed, 0 to remove and 2 not upgraded.
Need to get 242MB of archives.
After unpacking 678MB of additional disk space will be used.

and it completed without any problems. I also do not recall having any problems with dpkg recently.
What OBP version do you have in these machines?

I have a 2.25 from Sun in one, a 2.25R from ROSS in another one and a 2.25W (?) from an HyperSTATION in the third one. Tested modules are single and dual RT-626 with a VSIMM (4 and 8MB) and 448 MB. I think it is not an hardware trouble because all configurations I have tried return exactly the same error. Hardware of the main station I use for tests are validated with Solaris9 and without any trouble during several days (but I cannot use three or four CPU with Solaris9 without having "Watchdog reset!", all combinaisons with more than two CPU are not stable. Same results on the three stations. If I have time, I shall try to install a Solaris 2.7...).

ISTR that to run latest HyperSPARC CPUs from Ross you need either 2.25 from Sun, or 2.25R from Ross. If you are running anything lower, I suggest you try to upgrade your firmware, see http://www.sunshack.org/data/bootroms.html
for details.

Maybe this trouble is related to the trouble I see with two SuperSPARC's (Oops in readv_pipe). I don't know...



Reply to: