[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#353727: marked as done (linux-source-2.6.15: HP-INTEL MEGARAID SCSI controller not detected)



Your message dated Fri, 13 Oct 2006 16:52:54 -0600
with message-id <20061013225254.GB4820@colo>
and subject line closing
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: linux-source-2.6.15
Version: 2.6.15-4
Severity: important


Kernel 2.6.15 cannot be installed on old HP Netserver L(H)3000 equipped with various INTEL based MegaRAID SCSI controller.
Altough manually loading megaraid, megaraid_mbox, megaraid_mm or megaraid_sas, no drives are detected.
This problem occurs on 3 server equipped with differents cards (Integrated HP NetRAID T5, HP NetRAID-3Si)


I do believe this is caused by part of the Debian patch "drivers-scsi-megaraid_splitup.patch.bz2",
namely the one modifying "static struct pci_device_id megaraid_legacy_pci_tbl[]" because it remove references to 
-       {PCI_VENDOR_ID_INTEL, PCI_DEVICE_ID_AMI_MEGARAID3,
-               PCI_ANY_ID, PCI_ANY_ID, 0, 0, 0},
that seems to cover hte above HW.

I'm in no way competent to produce a patch so I leave this to you :)

See also bug report #317258 for similar problem.

With best regards.

Paul


-- System Information:
Debian Release: testing/unstable
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.4.27-2-686-smp
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

Versions of packages linux-source-2.6.15 depends on:
ii  binutils             2.16.1cvs20060117-1 The GNU assembler, linker and bina
ii  bzip2                1.0.3-2             high-quality block-sorting file co

Versions of packages linux-source-2.6.15 recommends:
ii  gcc                       4:4.0.2-2      The GNU C compiler
ii  libc6-dev [libc-dev]      2.3.5-13       GNU C Library: Development Librari
ii  make                      3.80+3.81.b4-1 The GNU version of the "make" util

-- no debconf information


--- End Message ---
--- Begin Message ---
Version: 2.6.16-1

If this was fixed in 2.6.16-rcX it should still be fixed, so closing.

-- 
dann frazier


--- End Message ---

Reply to: