[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#387760: linux-modules-extra-2.6: adding linux-wlan-ng modules

On Sat, Sep 16, 2006 at 06:10:32PM +0200, Bastian Blank wrote:
> tags 387760 moreinfo
> thanks
> On Sat, Sep 16, 2006 at 05:20:16PM +0200, Victor Seva wrote:
> > Please add linux-wlan-ng modules.
> The copyright file is not appropriate. It lists the MPL which is
> incompatible with the GPL and the modules can't be used under this
> license.

My understanding is that it is dual-licenced, but then maybe i am wrong.
Victor, can you comment on this ?

Also, Bastian, why is the modules being MPL a problem ? I mean we have
binary-only modules and such, and it should be ok. The current idea is that
the module interface boundary, as long as it doesn't use GPL-only symbols,
constitute a clean enough barrier so as to not cause GPL-compatibility


Sven Luther

Reply to: