[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#349354: Bug#369207: sarge->sid dist-upgrade is impossible, gnome/udev/kernel circular dep

On Sun, May 28, 2006 at 11:22:35AM +0200, Marco d'Itri wrote:
> On May 28, Sven Luther <luther@debian.org> wrote:
> > Now, i tried installing the linux-image package, but apt didn't let me do
> > this, because of the above installability problems, resulting in a broken
> > apt/dpkg database, and no easy way to go out of this without removing the
> > whole gnome packages, which is not desired.
> If your system is already in this state I think you just need to install
> the kernel package (and its dependencies) using dpkg -i and then
> continue as usual.

I didn't read the message and didn't touch the magic file, so i couldn't
install a new kernel.

> > I beleive i will be able to go out of this by some creative apt/dpkg
> > overriding, and maybe hand intervention, but we can't release etch this way.
> So far nobody managed to propose anything better, anyway feel free to
> share your toughs in #349354 of which this bug is a duplicate.

As discussed on irc, the best solution for this is to use debconf to inform
the user about this problem, and ask him if he wants to upgrade all the same,
defaulting to no. IDeally this could be done in such a way as to not make the
system un-upgradable.

I don't know, maybe hal and co can pre-depend on the right udev version or
something ?


Sven Luther

Reply to: