[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#358859: linux-headers-2.6.16-1-686: modules-assistant reports "unconfigured source"

Package: linux-headers-2.6.16-1-686
Version: 2.6.16-2
Severity: normal

Hi. I have two kernel modules which I build from source, both of which worked
perfectly well with 2.6.15 but both fail when trying to compile for 2.6.16.

When I tried building madwifi, module-assistant reported "unconfigured source" 
when examining the linux-headers-2.6.16-1-686 tree. Building the module didn't

When I tried building the nvidia kernel module, I received lots of error messages
that seem to me to be related to the kernel source headers not having been 
configured, the same kind of problem as module-assistant reported. I dumped the
nvidia build messages to a file and will append them to this ticket in a separate
message so things don't get too messy.


-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-686
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)

Versions of packages linux-headers-2.6.16-1-686 depends on:
ii  linux-headers-2.6.16-1        2.6.16-2   Common header files for Linux kern

linux-headers-2.6.16-1-686 recommends no packages.

-- no debconf information
# select which makefile to use.
rm -f /usr/src/modules/nvidia-kernel/nv/Makefile || true
if [ 6 = 6  ]; then \
	     cd /usr/src/modules/nvidia-kernel/nv ; \
	     ln -s Makefile.kbuild Makefile ; \
	     cd .. ; \
	     if [ 0  = 1 ] ; then \
	        dpatch apply 04_minion ; \
	     fi ; \
	     if [ 0 = 1 ]; then \
	     	dpatch apply 01_sysfs ; \
		dpatch status 01_sysfs >patch-stamp ; \
		dpatch apply 02_pcialias ; \
               	dpatch status 02_pcialias >>patch-stamp ; \
	     fi ; \
if [  6 = 4  ]; then \
	     cd /usr/src/modules/nvidia-kernel/nv ; \
	     ln -s Makefile.nvidia Makefile ; \
	     cd .. ; \
#nothing here anymore
touch configure-stamp
if [ -f /usr/src/modules/nvidia-kernel/debian/control.template ]; then \
		cp  /usr/src/modules/nvidia-kernel/debian/control.template /usr/src/modules/nvidia-kernel/debian/control; \
Kernel compiler version : 4.0.3
Detected compiler version : 4.0.3
Using compiler gcc-4.0 version 4.0.3
touch /usr/src/modules/nvidia-kernel/nv/gcc-check
touch /usr/src/modules/nvidia-kernel/nv/cc-sanity-check
## Main Make ##
IGNORE_CC_MISMATCH=1 CC="gcc-4.0"  /usr/bin/make -C /usr/src/modules/nvidia-kernel/nv -f Makefile SYSSRC=/usr/src/linux-headers-2.6.16-1-686   KBUILD_PARAMS="-C /usr/src/linux-headers-2.6.16-1-686 SUBDIRS=/usr/src/modules/nvidia-kernel/nv" module;
make[1]: Entering directory `/usr/src/modules/nvidia-kernel/nv'

NVIDIA: calling KBUILD...
make CC=gcc-4.0 -C /usr/src/linux-headers-2.6.16-1-686 SUBDIRS=/usr/src/modules/nvidia-kernel/nv modules
make[2]: Entering directory `/usr/src/linux-headers-2.6.16-1-686'
  CC [M]  /usr/src/modules/nvidia-kernel/nv/os-interface.o
make[2]: Leaving directory `/usr/src/linux-headers-2.6.16-1-686'
nvidia.ko failed to build!
make[1]: Leaving directory `/usr/src/modules/nvidia-kernel/nv'

---------Following was dumped to console, redirect ">" didn't catch it:
In file included from include/linux/list.h:7,
                 from include/linux/wait.h:23,
                 from include/asm/semaphore.h:41,
                 from include/linux/sched.h:20,
                 from include/linux/module.h:10,
                 from /usr/src/modules/nvidia-kernel/nv/nv-linux.h:47,
                 from /usr/src/modules/nvidia-kernel/nv/os-interface.c:26:
include/linux/prefetch.h: In function 'prefetch_range':
include/linux/prefetch.h:62: warning: pointer of type 'void *' used in arithmetic
In file included from include/linux/dmapool.h:14,
                 from include/linux/pci.h:522,
                 from /usr/src/modules/nvidia-kernel/nv/nv-linux.h:71,
                 from /usr/src/modules/nvidia-kernel/nv/os-interface.c:26:
include/asm/io.h: In function 'check_signature':
include/asm/io.h:258: warning: wrong type argument to increment
In file included from /usr/src/modules/nvidia-kernel/nv/os-interface.c:26:
/usr/src/modules/nvidia-kernel/nv/nv-linux.h:715:2: warning: #warning "conftest.sh failed, assuming remap_page_range(4)!"
/usr/src/modules/nvidia-kernel/nv/os-interface.c: In function 'os_set_mlock_capability':
/usr/src/modules/nvidia-kernel/nv/os-interface.c:1375: error: 'struct task_struct' has no member named 'rlim'
make[3]: *** [/usr/src/modules/nvidia-kernel/nv/os-interface.o] Error 1
make[2]: *** [_module_/usr/src/modules/nvidia-kernel/nv] Error 2
make[1]: *** [mdl] Error 1
make: *** [build-stamp] Error 2

Reply to: