[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#357450: marked as done (udev: timeout in initramfs-tools/scripts/init-premount/udev to short for 17 scsi disks)

Your message dated Sun, 19 Mar 2006 23:53:47 +0100
with message-id <20060319225347.GA13674@nancy>
and subject line Bug#357450: udev: timeout in initramfs-tools/scripts/init-premount/udev to short for 17 scsi disks
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

--- Begin Message ---
Package: udev
Version: 0.087-2
Severity: normal


I have a system with 17 scsi disks on 2 aic7xxx controllers.
Loading the modules takes approximatly 36 seconds, but
has a timeout of 30 seconds.

As a result a shell is spawnd on the console, but any message
that this has happend (as well as the initial shell prompt) is
overwritten by kernel output. Pressing Ctrl-D resumes normal

Disabling the timeout-code worked for me.

Maurice Massar

-- Package-specific info:
-- /etc/udev/rules.d/:
total 0
lrwxrwxrwx 1 root root 20 2006-02-22 10:39 020_permissions.rules -> ../permissions.rules
lrwxrwxrwx 1 root root 19 2006-02-22 10:39 cd-aliases.rules -> ../cd-aliases.rules
lrwxrwxrwx 1 root root 13 2006-02-22 10:39 udev.rules -> ../udev.rules
lrwxrwxrwx 1 root root 19 2006-02-22 10:39 z20_persistent.rules -> ../persistent.rules
lrwxrwxrwx 1 root root 12 2006-02-22 10:39 z50_run.rules -> ../run.rules
lrwxrwxrwx 1 root root 16 2006-02-22 10:39 z55_hotplug.rules -> ../hotplug.rules
lrwxrwxrwx 1 root root 15 2006-02-22 10:39 z60_hdparm.rules -> ../hdparm.rules
lrwxrwxrwx 1 root root 17 2006-02-22 10:39 z70_hotplugd.rules -> ../hotplugd.rules

-- /sys/:

-- Kernel configuration:

-- System Information:
Debian Release: testing/unstable
  APT prefers unstable
  APT policy: (500, 'unstable'), (1, 'experimental')
Architecture: i386 (i686)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.15-1-k7
Locale: LANG=en_US.UTF-8, LC_CTYPE=ja_JP.UTF-8 (charmap=UTF-8)

Versions of packages udev depends on:
ii  initscripts                  2.86.ds1-13 Scripts for initializing and shutt
ii  libc6                        2.3.6-3     GNU C Library: Shared libraries an
ii  libselinux1                  1.28-4      SELinux shared libraries
ii  lsb-base                     3.0-16      Linux Standard Base 3.0 init scrip
ii  makedev                      2.3.1-80    creates device files in /dev
ii  sed                          4.1.4-5     The GNU sed stream editor

udev recommends no packages.

-- no debconf information

--- End Message ---
--- Begin Message ---
Version: 0.56

fixed  by latest initramfs-tools in unstable, pasting changelog:

 * scripts/init-premount/udev_helper: Source the relevant definition to get
   it really run. Thanks to Maurice Massar <massar@unix-ag.uni-kl.de>.
   (closes: #357450)

your testing was very much appreciated. :)


--- End Message ---

Reply to: