[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#354458: Kernel panic after upgrading initramfs-tools


Following my own idea from the previous mail: I found initramfs-tools
0.55b on p.d.o. and downloaded it in the chroot which I described in
the previous mail. There I installed it and reran the initramfs-tools
update from the very first mail from you and rebooted.

Hey! The problem with the "no init found" is gone! So, the cause was
in the initrd after all! Altough, it booted a lot further, it still
didn't complete it: when it wants to mount the root fs, it gives an
error that it can't find /dev/hda6 (and drops into BusyBox). I suppose
this is because /dev hasn't been populated yet... So I tried without
the root= kernel option. This gives another error:
Begin: Mounting root filesystem...
Begin: Running /scripts/local-top
/scripts/local-top/lvm: 36: vgchange: not found
ALERT! does not exist. Dropping to a shell!

And again I end up in the BusyBox.

Whwat do I do now??

2006/3/17, Manuel Bilderbeek <manuel.bilderbeek@gmail.com>:
> Hi,
> Next try: I ran grub-install from the chroot, mounting with -o dev
> made this work. I even did an update-grub and got a menu.lst. After
> setting it all up, I could indeed select the image and attempt a boot.
> But I get exactly the same thing: no init found.
> So, it doesn't seem to be a grub problem.
> Maybe the initramfs update screwed something up?
> I'm very close to buying a new harddisk and doing a fresh install, but
> I would really appreciate it if you can help me still.
> --
> Grtjs,
> Manuel
> PS: http://manuel.msxnet.org/


PS: http://manuel.msxnet.org/

Reply to: