[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#349354: initramfs-tools - kernel -udev dependency loop

On Thu, Mar 02, 2006 at 07:54:08PM -0500, Adam C Powell IV wrote:
> The new upgrade procedure fails on alpha, regardless of the kernel
> workaround, there's still a udev - initramfs-tools dependency loop which
> interrupts the udev postinst, and the failures cascade from there:
> # touch /etc/udev/kernel-upgrade
> # dselect
> Reading package lists... Done
> Building dependency tree... Done
> 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
> 8 not fully installed or removed.
> Need to get 0B of archives.
> After unpacking 0B of additional disk space will be used.
> Do you want to continue [Y/n]?
> Setting up udev (0.085-1) ...
> Kernel upgrade mode, udevd has not been restarted.
> Please reboot the system as soon as possible.
> Kernel version too old.  initramfs-tools requires at least 2.6.12.

hmm why?
could you put as local workaround an set -x on top in
/usr/sbin/mkinitramfs, would really like to know how we got called



Reply to: