[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: linux-2.6 ftbfs on testing

On Sun, Feb 12, 2006 at 07:33:04PM +0100, Norbert Tretkowski wrote:
> It's currently not possible to build linux-2.6 with testing, because
> 2.6.15-4 build-depends on kernel-package (>= 10.029), but testing has
> 9.008.4. Looks like the testing scripts don't consider build-depends.

That's correct. Just as with recommends, unsatisfiable build-depends are
not being considered blocking propagation, for basicly the same reason:
unsatisfiability affects only a small minority of the normal usage of a
package, and therefore is less important -- not important enough to make
transitions even harder. In this case for example, it was hard to get
2.6.15 in testing.

Those issues should be solved before etch release though, so once the
release is nearing, it buys to either manually care for these issues, or
maybe enable britney to do pay attention to at least build-depends.

In this particular instance, I asked Manoj to consider inserting a brief
stabilizing period for kernel-package, so it likely shouldn't take too
long anymore for an adequate k-p to enter testing.


Jeroen van Wolffelaar
Jeroen@wolffelaar.nl (also for Jabber & MSN; ICQ: 33944357)

Reply to: