[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#329355: Kernels compiled from kernel-source-2.4.27 can't boot on x86_64.

Hash: SHA1

Hi again.

On Wed, Sep 21, 2005 at 07:55:27PM +0200, Frederik Schueler wrote:
> the amd64 port does not support 2.4 kernels, and there are no plans
> top change this.

ACK. I guess I missed that part in the release notes... I re-read the
whole thing anew just now. There is no concrete statement that 2.4 will
never ever run on x86_64. The sentence "For the AMD64 architecture only
a 2.6 kernel is available" could be interpreted as "we only build the
2.6 kernel but, hey, here's the code for an earlier one too". I also
read that chapter 4 about moving up from a 2.4 to a 2.6 kernel and it
doesn't seem as if one couldn't go the other way round either.

Anyway, if it weren't for this wretched sata controller thing, I
would've gone straight for a 2.6 kernel. BTW the bug report was
"automagically" raised to 'serious' status by reportbug (no builds of
kernel-image-2.4.27 could be found -- obviously -- so it thought it was
something more than what it actually was). 

Oh well... Back to 2.6, then. Sorry for the noise. 

Version: GnuPG v1.4.1 (GNU/Linux)
Comment: Nikos "Nikolai" Ntarmos <ntarmos@ceid.upatras.gr>


Reply to: