[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#322004: kernel-source-2.6.8: Fails to compile on a X86_64 platform

tag 322004 +sid
tag 322004 +wontfix

On Thu, Aug 11, 2005 at 05:19:12PM +0200, Manolo Díaz wrote:


> >>arch/x86_64/kernel/entry.S: Assembler messages:
> >>arch/x86_64/kernel/entry.S:81: Error: Macro with this name was already defined
> >>arch/x86_64/kernel/entry.S:100: Error: Macro with this name was already defined
> >>make[1]: *** [arch/x86_64/kernel/entry.o] Error 1
> > 
> > 
> > That is very odd. You have gcc 3.3 which I believe should work.
> > Could you try this with one the configuration supplied
> > with one of the amd64 kernel images?
> > 
> Yes, I've just tried it with "config-2.6.8-11-amd64-k8". The same problem.

On Thu, Aug 11, 2005 at 06:13:30PM +0200, Manolo Díaz wrote:
> Tried again with gcc-3.4 and gcc-4.0 with the same results.


I spoke to Frederik Schueler about this problem, and he
told me that it was a toolchain problem in sid. 

We are actually planning to remove kernel-source-2.6.8 from
sid in the near future. So could you please either use
linux-source-2.6.12 from sid, or compile on sarge.

In any case, its pretty difficult to fix this problem in 
sid (or so I have been told), and the problem should not
manifest in sarge, so I am going to tag it sid and wontfix.
Hopefully others with the same problem will see this.



Reply to: