[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#320053: kernel-image-2.6.8-2-686: Installing it with sarge leads to failing at booting next time



On Tuesday 26 July 2005 19:27, Stefan Esterer wrote:
> After i choose the Sarge install in grub the kernel stops after some
> time with :
> modprobe: FATAL: Error inserting pciehp
> (/lib/modules/2.6.8-2-686/kernel/drivers/pci/hotplug/shpchp.ko):
> Operation not permitted
> shpchp: can't be loaded
> [...]
> hw_random: can't be loaded
> [...]

Everything up to here is "normal". These modules are not supported by your 
hardware but do no harm. Just blacklist them for both discover and 
hotplug and you will be fine.

> Unable to handle kernel NULL pointer dereference at virtual adress
> 00000024
> [...]
> i810_audio: can't be loaded
> [...]

This one looks very much like a problem I've seen in several installation 
reports. [1] gives the best summary and status of the problem and has a 
workaround. Could you check that's the same issue?

Basic problem: we really need someone who has the hardware and is willing 
to test solutions. Could you do that?
The first step would be: check if the problem still occur with the 2.6.12 
kernel. The second step would be: get in touch with the ALSA people and 
try to get the problem solved (maybe testing with latest drivers from CVS 
first).

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=298623

Cheers,
FJP

(P.S. Please give a little bit more of the console output next time; it 
was just chance that I recognized the issue from the two relevant lines.)

Attachment: pgpHQKMuTUPi5.pgp
Description: PGP signature


Reply to: